HP scanner not working after upgrading to Fedora 38

I upgrade to 38 and now my printer will not scan…What is up with that…

Is this an HP scanner perhaps?

LMAO! yes…

Is this a printer/scanner combo and what model is it?

It is an HP Laserjet Pro CM1415fnw color MFP

Are you able to just print?

If you can print and not scan (I had this issue as well), I had to update with hp-plugin.

Run this in a terminal as your regular user (no-sudo)

hp-plugin -i
Do you wish to download and re-install the plug-in? (y=yes*, n=no, q=quit) ? y
Enter option (d=download*, p=specify path, q=quit) ? d

You’ll be asked for your password to continue.

Let that finish and reboot. See if that helps. HP drivers lately have been a little unstable. There are posts on Arch/Ubuntu/Suse/Etc about this particular issue.

In order to use the scanner on an HP MFP printer it is mandatory to configure the printer using hplip, which provides 2 different commands to make that possible.

hp-setup assists in configuring the printer itself and installs the driver file. It also has an option to install the plugin which is proprietary and required to access the scanner functions.

As a separate command hp-plugin is available to install (or reinstall) the plugin. A reinstall will be necessary when the hplip tool is updated since the hplip package and plugin must match on version numbers.

If you want to manage the printer from a gui then install the hplip-gui package and it makes printer management easy.

The only part of that not available directly from fedora is the actual plugin for the scanner.

I tried them I get a -2 error and it quits.

Is it saying that it failed due to bad file signatures?

If so you can download the files you need from here: Index of /download/printdriver/auxfiles/HP/plugins

Make sure you download the latest (3.23.5) .run AND the corresponding .asc file.

Open a terminal

cd ~/Downloads

./hplip-3.23.5-plugin.run --quiet


Give that a try.

Some additional context here: HP Developers Portal | What is the HPLIP Binary Plug-In and How Do I Install It?

Have you tried using an old kernel ?

The plugin can be downloaded directly from HP Developers Portal | Plugins then installed as a local file either by running it directly or using the hp-plugin command to install it. The related .asc file contains the pgp signature for that file so the file integrity can be verified and it can be imported if needed.

Note that the version number of the plugin must match the version of hplip itself or the scanner will not work. The installed hplip version is automatically updated when the system is upgraded, but the plugin requires a manual update.

1 Like

I solved this same issue (my printer model was the black and white laser printer mfp_m26nw) by uninstalling hplip and installing hplip from hp’s website using the link above. I used the interactive mode instead of the hplip-gui as Fedora 38 was missing a few of the required python packages for the gui. I was able to get all the functionality back from previous versions of the install.

I believe that the issue lies with Fedora’s version of the package, as I have another hp-all-in-one inkjet that also quit functioning. For some reason beyond anything I’d like to look up tonight, the checksums of the new drivers don’t match the version of hplip, resulting in printer failure. I hope this helps.

Uninstalling hplip does not remove an already installed printer driver in /etc/cups/ppd. Thus the effort seems a bit over the top.

I simply do a normal dnf upgrade then if the printer has an issue I use the gnome settings tool to remove the currently defined printers following which I use hplip (either the gui, or using the cli with hp-setup) and configure the printer again. It always works, and during the setup it asks if the plugin for the scanner should be installed – then when told yes it downloads that directly from hp and installs it.

Note that if you fail to remove hplip that is provided by fedora before installing the package from another source there may be file conflicts caused and potential problems in the future – especially when a routine update of hplip overwrites files from the other source.

As far as missing a few of the required python packages for the gui. I don’t understand what you mean. Installing hplip-gui from the fedora repo automatically brings in any dependencies that are not already there. It has always worked 100% for me.

On a newly installed F38 system, that I had upgraded to F39 (Beta) then installed hplip-gui I get this.

# dnf install hplip-gui
Last metadata expiration check: 2:34:02 ago on Sat 07 Oct 2023 12:40:42 PM EDT.
Dependencies resolved.
 Package                                    Architecture            Version                           Repository               Size
 hplip-gui                                  x86_64                  3.23.5-8.fc39                     fedora                  1.3 M
Installing dependencies:
 python-qt5-rpm-macros                      noarch                  5.15.9-6.fc39                     fedora                  8.9 k
 python3-pyqt5-sip                          x86_64                  12.12.2-1.fc39                    fedora                   88 k
 python3-qt5                                x86_64                  5.15.9-6.fc39                     fedora                  1.2 M
 python3-qt5-base                           x86_64                  5.15.9-6.fc39                     fedora                  3.3 M
 python3-reportlab                          noarch                  4.0.4-3.fc39                      fedora                  3.3 M
 qt5-qtconnectivity                         x86_64                  5.15.10-2.fc39                    fedora                  464 k
 qt5-qtlocation                             x86_64                  5.15.10-3.fc39                    fedora                  3.2 M
 qt5-qtmultimedia                           x86_64                  5.15.10-2.fc39                    fedora                  811 k
 qt5-qtsensors                              x86_64                  5.15.10-2.fc39                    fedora                  230 k
 qt5-qtserialport                           x86_64                  5.15.10-2.fc39                    fedora                   65 k
 qt5-qttools-common                         noarch                  5.15.10-3.fc39                    fedora                   11 k
 qt5-qttools-libs-designer                  x86_64                  5.15.10-3.fc39                    fedora                  2.7 M
 qt5-qttools-libs-help                      x86_64                  5.15.10-3.fc39                    fedora                  157 k
 qt5-qtwebchannel                           x86_64                  5.15.10-2.fc39                    fedora                  100 k
 qt5-qtwebsockets                           x86_64                  5.15.10-2.fc39                    fedora                   87 k

Transaction Summary
Install  16 Packages

As you can see all the required python and qt packages are automatically pulled in.

Really the whole idea of requiring a separate propriety program to send documents to a print is abhorrent! You should be able to just print, not have to go though hoops every time you upgrade your system.

I went though the same dramas as above. I worked at it quite hard to get the printer working again. In the end I don’t even know WHAT I finally did to fix the problem. It is ridiculous.

If I had a choice I would ditch HP printers all together!

You do have a choice –
and others.

No one here is locking you into an HP world.