Howto disable zchunk on rpm-ostree

[wuf31@x1c6-jhon-xyz ~]$ rpm-ostree install wireguard
Checking out tree 3a85ef6... done
Enabled rpm-md repositories: tlp rpmfusion-nonfree-updates rpmfusion-free-updates tlp-updates fedora updates rpmfusion-free rpmfusion-nonfree copr:copr.fedorainfracloud.org:abn:throttled fedora-cisco-openh264
rpm-md repo 'tlp' (cached); generated: 2020-04-29T19:24:49Z
rpm-md repo 'rpmfusion-nonfree-updates' (cached); generated: 2020-08-11T09:22:41Z
rpm-md repo 'rpmfusion-free-updates' (cached); generated: 2020-08-11T09:04:39Z
rpm-md repo 'tlp-updates' (cached); generated: 2020-04-29T19:24:56Z
rpm-md repo 'fedora' (cached); generated: 2020-04-22T22:22:36Z
Updating metadata for 'updates'... done
error: Updating rpm-md repo 'updates': cannot update repo 'updates': Yum repo downloading error: Downloading error: Unable to initialize zchunk file repodata/729250958efcc4f61b21dc486d0f780255ac396cdbd48f3b6a3a6835df714a82-comps-Everything.x86_64.xml.zck: Unable to set zchunk file descriptor for repodata/729250958efcc4f61b21dc486d0f780255ac396cdbd48f3b6a3a6835df714a82-comps-Everything.x86_64.xml.zck: Unable to find multipart download range
; Last error: Zchunk error: Unable to find multipart download range

I got this error. How can I disable zchunk on rpm-ostree ?
I’ve tried putting

[main]
zchunk=False

on /etc/dnf/dnf.conf
and clearing /var/cache/rpm-ostree/*
but nothing seems to work.

Thank you :pray:

Hello @changwuf31,
Welcome to the discussion forum. For user help it is usually best to ask at (appropriately named) ask.fedoraproject.org. Having said that from this …

I would have to ask are you using a proxy server?

No, I’m not behind a proxy.

I’ve also tried to edit /etc/yum.repos.d/fedora-updates.repo.
commenting metalink, and add baseurl

baseurl=http://download.nus.edu.sg/mirror/fedora/linux/updates/$releasever/Everything/$basearch/

also added zchunk=0 there.

But still encounter the same error.
Btw, I’ve already asked at the ask.fedoraproject.org, and I’m redirected to this forum.

Can you try keeping zchunk enabled and doing a repo metadata cleaning-up with:

sudo rpm-ostree cleanup --repomd

Aah… thank you, I got it working now.
I changed the internet connection to using my mobile as a hotspot.
Seems like my ISP is using some sort of proxy behind the scene.
Is there any way to circumvent this issue, without me using the metered bandwidth of my phone.

Thank you & Best Regards :+1: :pray:

@siosm I’ve already solved the issue.

But I’ll try this should I encounter this issue again.

Thank you :+1:

Hello @changwuf31,
You’re welcome. And as @siosm was asking, updating the repomd would have helped with this I think since it appears to be similar to https://bugzilla.redhat.com/show_bug.cgi?id=1706627 but this bug specifically notes dnf. Rpm-ostree uses libdnf for package layering functions. Glad you solved it though.

Sorry @jakfrost, on Ask Fedora I pointed @changwuf31 here just because Silverblue is not still widely used like Fedora Workstation (or other Spins/Editions) can be, less users, still a relatively new concept, etc. And since this issue seems not related to using the system, but like some sort of bug, there could be more chances to diagnose the problem here on discussion.f.o

Please have a look to these bug reports, they seems strictly related:

And this PR to libdnf:

That’s all good. I was using my standard rote for new comers with support issues. I’ll take a look at those since, yeah they do appear to be related to the topic. Thanks for stopping by!

1 Like

Thank you @jakfrost @alciregi or all the help provided. :+1:

FYI, I encounter the error again, and ```rpm-ostree cleanup --repomd` doesn’t help.