How to use mux switch in Asus tuf f15 2022 FX507ZM?

So i got the asus tuf f15 2022 FX507ZM i7 12700H + rtx 3060. It has a mux switch that is only configurable in armory crate. I cannot find any guide as to how enable it on linux. Moreover intel drivers has a bug so i cannot use the screen at 300hz while connected to iGPU. If i set mux switch to dedicated and boot into fedora, it never reaches boot on nvidia drivers. On noveau drivers, it does reaches boot but the rendering is done by iGPU yet.
How can i fix it and run my display at 300hz?

Ok actually you can’t switch graphic card when game is running

if fedora detects your integrated card and nvidia card

then open gnome app launcher and right on app
you should see open with dedicated card or if your default is nvidia open with integrated card

1 Like

Is your nvidia card detected?

do screenshot of settings<about

Yes it is detected. But the display is connected to intel iGPU

$ inxi -Gxx
  Device-1: Intel Alder Lake-P Integrated Graphics vendor: ASUSTeK
    driver: i915 v: kernel arch: Gen12.2 ports: active: eDP-1 empty: DP-1,DP-2
    bus-ID: 0000:00:02.0 chip-ID: 8086:46a6
  Device-2: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] vendor: ASUSTeK
    driver: nvidia v: 515.57 arch: Ampere bus-ID: 0000:01:00.0
    chip-ID: 10de:2520
  Device-3: Sonix USB2.0 HD UVC WebCam type: USB driver: uvcvideo
    bus-ID: 3-7:2 chip-ID: 322e:202c
  Display: x11 server: X.Org v: 1.20.14 with: Xwayland v: 22.1.3
    compositor: gnome-shell v: 42.3.1 driver: X: loaded: modesetting,nvidia
    unloaded: fbdev,nouveau,vesa alternate: nv gpu: i915 display-ID: :1
    screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96
  Monitor-1: eDP-1 mapped: eDP-1-1 model: TL156VDXP0101 res: 1920x1080
    dpi: 142 diag: 395mm (15.5")
  OpenGL: renderer: NVIDIA GeForce RTX 3060 Laptop GPU/PCIe/SSE2
    v: 4.6.0 NVIDIA 515.57 direct render: Yes

So, i can neither change the refresh rate from settings as intel drivers has a bug which doesn’t let me do that nor can i use xrandr.

But if i am able to connect nvidia gpu directly to the display using mux switch that might work…

moreover here is nvidia-settings

Are you using x11?

yes i am using x11

this should help you

Yup tried that doesn’t work.
That’s a guide for optimus, not for mux switch you can look here Mux Switch, Nvidia Optimus and Smart Shift | Learn More . I sadly cannot find any guide for it. :cry:

Did you try switching graphic card in your bios/uefi?

There is no option in the bios. It only get changed through the armoury crate software

did you tried in uefi advanced mode

Cause when you start uefi on asus laptop you are in ez mode

ok try this

yeah no options there for mux switch
and yes i did use supergfxctl sadly doesn’t work in accessing mux switch

You can try flashing hiren’s boot cd PE on usb

remember to flash usb with unetbootin

Hi, have you tried this?

maybe, they Upgraded it a bit

from that i saw they checked on checklist mux switch support
and yeah if it works then you can try

cool graphics quick tile for gnome