How to set an automatically configured printer as default?


I have a fresh installation of Fedora-34 beta on my Laptop.

When I open the “printers” dialog in the Gnome settings, there is a printer “Brother_MFC_L3750CDW_series”, which I did not configure. /etc/cups/printers.conf is empty. (Thus “automatically configured”, perhaps “autodetected” might be a better phrase.)

If I “unlock” the “printers” dialog, I can select “Use printer by default”. However, if I do that, there is an error message

cups-pk-helper: setting default printer to Brother_MFC_L3750CDW_series failed: client-error-not-found

in the command line, and the option is deselected immediately.

Any ideas, how I can make this printer the default for “lpd”, etc.?



1 Like

For the record: The behaviour is reproducable on another Laptop with Fedora 33.

1 Like
# List printers
sudo lpstat -t

# Set default printer
sudo lpadmin -d printer_name
1 Like