How to set 'Always on top' for an app mandatory?

Especially if the app has no titlebar.
I’ve search that option in the GNOME Tweaks, but there’s nothing.

Are you asking if it’s possible to automatically always make a particular app window “always on top” (as in each time you boot/log in)? I don’t think this functionality exists, at least I’m not aware of it.

If the app has no title bar, does “alt + spacebar” still work to give you access to the usual options?

1 Like

@ankursinha, yes, it works! But, if i hide that window, the problem returns. So I need to pick up the window’s menu every time when I use that application.

I’m trying this out here. I made this one window “always on top”, now it just says on top everywhere. Then I did the same thing and selected “hide” and it went away. Then, I went to the activities menu and selected it again, and the “always on top” setting remains, and it’s doing what it should now.

Let’s get some more info about your system though. What version of Fedora are you on, and what’s the Gnome-shell version etc.?

I’m now on F39 on X11.

1 Like

@ankursinha, well, my system is:

OS: Fedora Linux 38 (Workstation Edition) x86_64 
Kernel: 6.2.15-703.inttf.fc38.x86_64
Shell: zsh 5.9
DE: GNOME 44.5
Terminal: guake

Guake Terminal: 3.7.0
VTE: 0.72.2
VTE runtime: 0.72.2
Gtk: 3.24.38

It could just be a bug in F38’s version of gnome shell. Are you on X11 or Wayland? Could someone on F38 please try to reproduce this issue?

There’s Wayland.

1 Like

That’s a hilarious thing, but I can’t switch to GNOME Xorg. After that the system opens the logon screen again and again…

Could you ask a new topic for that please, just so we keep the two issues separate? The starting point again would be the logs—something is crashing somewhere and we need to know what.

1 Like