How to remove a folder in /usr usando rpm-ostree

Hello!, so basically , i have a theme bug in telegram, where it shows the wrong cursor, and with the wrong size, i tried a lot of workarounds that didn’t work(like setting XCURSOR_THEME, etc) the last one that i can’t test, is removing the /usr/share/icons/default/index.theme where it’s write inside

[Icon Theme]

, that is exactly wrong cursor that telegram is showing,
but i’m using kinoite, so it become weird in my system(where every program uses the breeze_icon, that is set on the system settings),
so, how can i remove that folder?, i though in creating a rpm-package to overlay on top using the rpm-ostree, and that overlay remove that /default/index.theme folder, but i don’t know how to do it, can someone help me in creating that overlay?, or have a better idea how to fix that issue, thank in advance!

System info:

  • Operating System: Fedora Linux 39
  • KDE Plasma Version: 5.27.8
  • KDE Frameworks Version: 5.109.0
  • Qt Version: 5.15.10
  • Kernel Version: 6.5.5-300.fc39.x86_64 (64-bit)
  • Graphics Platform: Wayland
  • Processors: 16 × AMD Ryzen 7 5700U with Radeon Graphics
  • Memory: 6.6 GiB of RAM
  • Graphics Processor: AMD Radeon Graphics
  • Manufacturer: LENOVO
  • Product Name: 82MF
  • System Version: IdeaPad 3 15ALC6

the Telegram is installed using flatpak

This is likely Issue #396: GTK Flatpak Apps not honouring Breeze-GTK (Kinoite 39) - SIG -

1 Like

worked! thank you very much!

btw, i updated my system and the bug is fixed, no need for the workaround anymore