How to install vdhcoapp needed to use DownloadHelper addones

Hey, on the addons website there a file for Debian Linux or tar.gz file.
How do I install it?

1 Like

I have to admit I have no idea what vdhcoapp or DownloadHelper is (please elaborate) but this all sounds like you could use


(which is in Fedora’s repositories)

1 Like

This is an extention that enable you to download videos that are streaming.

what is this?

OK this is nice!

Edit: I tried but this didn’t work for me (university website not youtube)
This is the website to download the software I need to install.

It says “based on youtube-dl”, why not use youtube-dl directly.

The name of youtube-dl is confusing, I agree, but the software works with almost any media streaming platform, not just youtube…

just give it a try:

youtube-dl URL

I got this Error

ERROR: Unsupported URL:

looks like they don’t want me to download the lecture, even if it is for private use :pensive: (no reliable internet connection at work)

[generic] view: Requesting header
[redirect] Following redirect to
[generic] view: Requesting header
WARNING: Falling back on generic information extractor.
[generic] view: Downloading webpage
[generic] view: Extracting information
ERROR: Unsupported URL:

That seems to be an authentication error. The video is not public, and when accessing it redirects you to a Single-Sign-On page (sso.apps.openu…). Not sure how to deal with it using youtube-dl. In that case the FF extension would be easier…

I guess you have to figure out how to compile the source for Fedora. The authors don’t provide rpm package, nor building instructions: GitHub - mi-g/vdhcoapp: Companion application for Video DownloadHelper browser add-on

If you fiddle around, you may be able to use youtube-dl using your browers cookies (after logging in): youtube-dl authentication - Google Search

OK, I will try that, Thank you!

1.- Downloadhelper is an add-on for firefox you can download here:

2.- To install vdhcoapp is a Companion Application, you have to install from source tar.gz:

Some operations required by Video DownloadHelper cannot be performed from within the browser. In order to be able to still do the job, the add-on relies on an external application that is called transparently. We call it the Companion Application .

a. Download form → here
b. and check → Extra step required to complete install


Linux targz installation

targz user-wide install - only your user

tar xf net.downloadhelper.coapp-1.5.0-1_amd64.tar.gz -C ~
~/net.downloadhelper.coapp-1.5.0/bin/net.downloadhelper.coapp-linux-64 install --user

targz system-wide install - all user’s

sudo tar xf net.downloadhelper.coapp-1.5.0-1_amd64.tar.gz -C /usr/local 
sudo /usr/local/net.downloadhelper.coapp-1.5.0/bin/net.downloadhelper.coapp-linux-64 install --system



Thank you for your answer,
So I opened the terminal in the file directory, where the file is located and did

$ install net.downloadhelper.coapp-linux-64 -t /home/me/install

*install is a directory I created, the install command required a destination.

The above command " install --user" returns “command not found”

cant tell if it actually did anything

1.- you’ve had to execute this step in order.,
2.- did you extrat it first…?
3.- First extract, this expand the Directory in your home…

tar xf net.downloadhelper.coapp-1.5.0-1_amd64.tar.gz -C ~

4.- Then, execute from your home:

~/net.downloadhelper.coapp-1.5.0/bin/net.downloadhelper.coapp-linux-64 install --user


VdhCoApp: VdhCoApp is ready to be used

5.- Open Downloaderhelper, click on preferences and expand Auxiliar Aplication installed:

Found  Aplication Auxiliar AplicaTiĂłn: *VdhCoApp 1.5.0*
Root Aplication: */usr/local/net.downloadhelper.coapp-1.5.0/bin/net.downloadhelper.coapp-linux-64*

6.- It doesn’t find click on → re-check



It worked

Fiinally, I got:

VdhCoApp: VdhCoApp is ready to be used

Thank you for the help!

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.