How to install pantum m6550nw printer driver?

How to install pantum m6550nw printer driver on fedora 35 workstation?

thx

I have a similar issue, I have M6500 Pantum and Fedora 38. The OS adds the printer but the file is not printed. I see on Pantum website there are drivers for Ubuntu only, meaning for every Linux distro that uses .deb packages.
There should be a way to use those drivers in Fedora, too. Any help?

If anyone finds this topic, I finally managed to print on Fedora using my Pantum M6500 Series. That’s how I did it:

  1. Download Linux Drivers from official source https://global.pantum.com/support/download/driver/
  2. You will download something like : Pantum Ubuntu Driver V1_1_99-1.zip
  3. Extract the .zip, find the pantum_1.1.99-1_amd64.deb
  4. Unpack it using dpkg
  5. sudo dnf install dpkg
  6. dpkg-deb -xv pantum_1.1.99-1_amd64.deb /home/youruser/folderwheretoextract (you can just type dpkg-deb -xv and then drag&drop the .deb file into the terminal, then finish the command).
  7. Navigate to the extracted folder and find the .ppd file in it. In my case it was in: /extratedfolder/usr/share/cups/model/Pantum
  8. Go to Settings/Printers and Fedora should already have identified that you have a connected printer. In my case the name was correct but the driver Fedora was using was an HP one. Hence the printer could not print any job. Find the Pantum printer and go edit details. Then Select .ppd file, and choose the one you just found.
  9. Lastly, copy the content of the filters, from /extractedfolder/usr/lib/cups/filter to the corresponding /usr/lib/cups/filter folder in your system.
  10. Print!

I am not sure if other files from the extractedfolder are needed to be copied in the corresponding location to the system, but for now the print option works. Not the scanner, though.

If your Pantum M6550NW aupports wifi it should support driverless printing (called Airprint on Apple systems, IPP elsewhere):

Nowadays applications send jobs in PDF and CUPS does the PDF-centric processing, already for 8 years, since the first release of cups-filters back in 2012. So PPD files do not really fit in the picture anymore, and they also had their shortcomings, especially being rather unflexible in the possible types of user-settable options. Also, the need to drop filters and PPDs into reserved directories of CUPS makes it difficult to provide CUPS and printer drivers in sandboxed packages, like Snaps.

1 Like

Looks to me like the files in <extracted folder>/usr/lib/x86_64-linux-gnu/sane/ would need to be put into the appropriate location on the system to provide the library files for sane to use the scanner.

$ ls -l usr/lib/x86_64-linux-gnu/sane/
total 216
lrwxrwxrwx. 1 user user     28 Jul 23  2020 libsane-pantum6500.so -> libsane-pantum6500.so.1.0.24
lrwxrwxrwx. 1 user user     28 Jul 23  2020 libsane-pantum6500.so.1 -> libsane-pantum6500.so.1.0.24
-rw-r--r--. 1 user user 140024 Jul 23  2020 libsane-pantum6500.so.1.0.24
lrwxrwxrwx. 1 user user     28 Jul 23  2020 libsane-pantum_mfp.so -> libsane-pantum_mfp.so.1.0.24
lrwxrwxrwx. 1 user user     28 Jul 23  2020 libsane-pantum_mfp.so.1 -> libsane-pantum_mfp.so.1.0.24
-rw-r--r--. 1 user user  77016 Jul 23  2020 libsane-pantum_mfp.so.1.0.24

and probably some others as well.

Yes, eventually I added all the content of usr, opt and etc in corresponding folders, but still Document Scanner app can´t find the scanner. Any new ideas? Or how can I see scanners in terminal?

It seems working out of the box in Ubuntu based distros, like stated in the Pantum manual: https://service-global.pantum.com/uploads/20181026/00defbe029a844eed7c058a6ec780151.pdf

usb-devices commands sees my printer as:

D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=232b ProdID=0e20 Rev=01.00
S:  Manufacturer=Pantum
S:  Product=M6500 series
S:  SerialNumber=CE5G004305
C:  #Ifs= 2 Cfg#= 1 Atr=c0 MxPwr=98mA
I:  If#= 0 Alt= 0 #EPs= 2 Cls=07(print) Sub=01 Prot=02 Driver=usblp
E:  Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
I:  If#= 1 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
E:  Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=82(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=83(I) Atr=03(Int.) MxPS=   8 Ivl=16ms

I noticed a Driver=(none), could it be that there is no driver for the scanner?

I tried alien to convert the .deb to a .rpm and it failed to install with a missing library file. (libjpeg.so.8 [twice]). I tried the normal trick of adding a link to the existing lib so the file name it was asking for was there but that did not work. My system has libjpeg.so.9.

If that printer is similar to the HP MFPs then it may need a proprietary plugin as is used with hplip to access the scanners.

1 Like

Is unpacking the deb using dpkg the same as converting it in .rpm and installing? BTW I have also failed the alien conversion.

And regarding the scanner, you may be right about the plugin. Unfortunately the manufacturer considers Ubuntu = Linux so their scanner work in Ubuntu only, as I see.

I update my solution above stating that it is easier than my instruction I wrote previously.

After extracting the driver (right now the version is .106 and not .99 anymore) you just merge the 3 folders you get in the corresponding location of you linux installation. So copy the 3 extracted folders: etc, opt, usr, to you root location / , merging the files. That’s it! After you connect turn on and connect the printer, then click “discover” it will automatically find the Pantum printer.