How to install new Cisco Packet Tracer 7.3 on Fedora 31 Workstation?


I had installed the previous version of Cisco Packet Tracer (7.2.2) on my Fedora 31 Workstation and it works fine. I have a training task for which I need to use the latest version (7.3) of this network simulator.
When I looked at Cisco file downloads, I found the only version for Debian distro in my Cisco Networking Academy account.
Maybe someone tried to install this program on Fedora / CentOS / RHEL and how did you do this? Maybe someone has a completed RPM file?



Hi.  Is dnf search apt returns something?  i’d heard that one can install apt on Fedora (not sure).

Hi! The terminal returns:

========================================================================================================= Name Exactly Matched: apt ==========================================================================================================
apt.i686 : Debian's Advanced Packaging Tool with RPM support
apt.x86_64 : Debian's Advanced Packaging Tool with RPM support

Then, probably (idk, better query “apt Fedora” before use):

dnf install  apt

# apt know how to work with .deb
apt install  XYZ

You need to convert that .deb file to .rpm and install that. I haven’t done that before but there is a program called alien on Fedora repos and there are articles about using on the internet.
First, install alien:

sudo dnf install alien

Then convert your downloaded .deb file and install it:

alien -r -c -i -v path/to/the/downloaded/file.deb

This will install it as a normal user. If your program needs to be installed by the root user, omit the -i switch and use the command below after converting.

sudo rpm -i path/to/the/converted/file.rpm

I haven’t used alien before, so please consult man alien if you need further guidance.

1 Like

Great thanks! :grinning: I’ll try your variant and @vits95 variant in the virtual machine. After all manipulations, I’ll give feedback.

1 Like

Both variants don’t solve this issue.

apt install  XYZ
  1. After installation apt command doesn’t found

  2. I tried to use alien with root and without root, but in both cases, I had only errors.

1 Like

I’ve installed PacketTracer on Fedora 31 Workstation in this way:

  1. Log into the Fedora GNOME Desktop
    Remove old version of PacketTracer (if necessary):
    rm -rf /opt/pt
    rm -rf /usr/share/applications/cisco-pt7.desktop
    rm -rf /usr/share/applications/cisco-ptsa7.desktop
    rm -rf /usr/share/icons/hicolor/48x48/apps/pt7.png

  2. Download from the netacad web site the PacketTracer_730_amd64.deb package.

  3. Open a terminal :
    mkdir -p tmp/pt730
    copy the PacketTracer_730_amd64.deb package to tmp/pt730

  4. We’re going to extract the deb file in this folder:
    cd tmp/pt730
    ar -xv PacketTracer_730_amd64.deb
    mkdir control
    tar -C control -Jxf control.tar.xz
    mkdir data
    tar -C data -Jxf data.tar.xz

  5. Copy PacketTracer files to install it:
    cd data
    cp -r usr /
    cp -r opt /

  6. Configure Gnome Environment:
    sudo xdg-desktop-menu install /usr/share/applications/cisco-pt7.desktop
    sudo xdg-desktop-menu install /usr/share/applications/cisco-ptsa7.desktop
    sudo update-mime-database /usr/share/mime
    sudo gtk-update-icon-cache --force --ignore-theme-index /usr/share/icons/gnome
    sudo xdg-mime default cisco-ptsa7.desktop x-scheme-handler/pttp
    ln -sf /opt/pt/packettracer /usr/local/bin/packettracer

  7. We have a problem with So, we’re going to compile a version of this library with the right option:
    Go to tmp folder
    mkdir libjpeg
    cd libjpeg/
    git clone GitHub - libjpeg-turbo/libjpeg-turbo: Main libjpeg-turbo repository ./
    mkdir build
    cmake -DWITH_JPEG8=1 -B ./build/
    cd build/
    sudo cp build/ /opt/pt/bin
    sudo ln -s /opt/pt/bin/ /opt/pt/bin/

  8. Log out and log into the Fedora GNOME Desktop to test.
    It should work…


The Packettracer 7.3.0 installation on Fedora 32 Workstation can be in the same way.
The shared library is missing.
Open a terminal:
sudo -s
cd /usr/lib64
ln -sf


Hi philpinch,

This command does not work.
(cmake: command not found)
Is this a mistake?

Thanx for help


a quick one, missing dependency:

sudo dnf install cmake



1 Like

Install cmake from the repositories.
When a command is missing, type : dnf provides <command_missing>.
For example : dnf provides cmake.
Then you know which package to install : dnf install cmake-3.17.2-1.fc32.x86_64 (or dnf install cmake)

1 Like

Thanx. PT works fine.
I’m happy


1 Like

Hello, I’ve tried all steps above mentioned but I can’t solve the problem with a missing library which is, It’s inside the bin folder but PT doesn’t seems to recognize it. Any ideas on how to solve this issue. Thanks in advance.

The LD_LIBRARY_PATH variable is probably missing at PacketTracer startup.

You must run the program with the script /usr/local/bin/packettracer which contains the following lines:
echo Starting Packet Tracer 7.3.0
export LD_LIBRARY_PATH=/opt/pt/bin
pushd /opt/pt/bin > /dev/null
/PacketTracer7 “$@” > /dev/null 2>&1
popd > /dev/null

The /usr/local/bin/packettracer file is a symbol link to /opt/bin/packettracer.

If you run the program from a graphical user interface, here is the content of the icon file /usr/share/applications/cisco-pt7.desktop:
[Desktop Entry]
Exec=/usr/local/bin/packettracer %f
Name=Packet Tracer 7.3.0


1 Like

I use KDE Plasma on Fedora 32
I followed in his footsteps and it didn’t work! You are experiencing the error below and I was unable to find the packages requested in the error in the repositories or RPM search sites.

#ldd PacketTracer7 | grep not
./PacketTracer7: ./ version `Qt_5_PRIVATE_API’ not found (required by ./PacketTracer7)

How do you run PacketTracer ?

The is provided by Cisco and stored in the /opt/pt/bin directory.
The LD_LIBRARY_PATH variable is probably missing at PacketTracer startup.

You must run the program with the script /usr/local/bin/packettracer which contains the following lines:
echo Starting Packet Tracer 7.3.0
export LD_LIBRARY_PATH=/opt/pt/bin
pushd /opt/pt/bin > /dev/null
/PacketTracer7 “$@” > /dev/null 2>&1
popd > /dev/null

The /usr/local/bin/packettracer file is a symbol link to /opt/bin/packettracer.


Yes, you’re right. It must be installed.

I can vouch that pillpinch comment is the solution at least for my Fedora 32 kernel 5.7.8-200.fc32.x86_64. I must point that you should use the recommended directory /tmp. I didnt and I was running around in circles until I followed this indications to the letter.
Also you must make the link for the libdouble-conversion library.

My system didnt had the libdouble-conversion library, and what ended up working for me was downloading it from (with browser, not wget): and extracted and created the link, my commands, feel free to adjust accordingly to your paths:

cd /home/manny/Downloads/
mkdir libdouble/
mv libdouble-conversion1_2.0.1-4ubuntu1_amd64.deb libdouble/libdouble-conversion1_2.0.1-4ubuntu1_amd64.deb
cd libdouble/
ar -xv libdouble-conversion1_2.0.1-4ubuntu1_amd64.deb
mkdir control
tar xvf control.tar.gz -C control
mkdir data
tar xvf data.tar.xz -C data
ln -sf /home/manny/Downloads/tmp/ubuntulibs/libdouble/data/usr/lib/x86_64-linux-gnu/ /opt/pt/bin/

Note: I cant make it run it from the icon, but instead with this sentence:

sudo /opt/pt/packettracer --no-sandbox

Thank you so much!

1 Like

First off: thank you if you are taking time to read this.

So I was able to functionally install Packet Tracer 7.3. in Fedora 32.

It worked just fine until recently, now executing Packet Tracer raises this error:

Fatal: This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.
Available platform plugins are: linuxfb, xcb.
/opt/pt/ptdebug: line 8:  3756 Aborted                 (core dumped) ./PacketTracer7 "$@"

Coincidently I updated with dnf update. Kernel got updated to: 5.7.10-201.fc32.x86_64. Not shure if it’s related.

I tried reinstalling Packet Tracer with no success. And I’ve searched the error with no success so far.
I’ve got no idea what to do, please anyone has a pointer of what to look or where to go?

I have also compiled what I could find:

Both files lie in folder:

And I ran this to see versions installed of qt5, libxcb and libqlinuxfb, it found nothing for libqxcb:

dnf list installed | grep 'qt5\|xcb\|linuxfb'
adwaita-qt5.x86_64                                 1.1.3-2.fc32                           @updates                                    
libX11-xcb.x86_64                                  1.6.9-3.fc32                           @anaconda
libxcb.x86_64                                      1.13.1-4.fc32                          @anaconda                                   
libxcb-devel.x86_64                                1.13.1-4.fc32                          @fedora                                     
qt5.noarch                                         5.13.2-2.fc32                          @fedora                                     
qt5-qdbusviewer.x86_64                             5.14.2-1.fc32                          @updates                                    
qt5-qt3d.x86_64                                    5.14.2-1.fc32                          @updates                                    
qt5-qtbase.x86_64                                  5.14.2-5.fc32                          @updates                                    
qt5-qtbase-common.noarch                           5.14.2-5.fc32                          @updates                                    
qt5-qtbase-gui.x86_64                              5.14.2-5.fc32                          @updates                                    
qt5-qtbase-mysql.x86_64                            5.14.2-5.fc32                          @updates                                    
qt5-qtbase-postgresql.x86_64                       5.14.2-5.fc32                          @updates                                    
qt5-qtconnectivity.x86_64                          5.14.2-1.fc32                          @updates                                    
qt5-qtdeclarative.x86_64                           5.14.2-1.fc32                          @updates                                    
qt5-qtdoc.noarch                                   5.14.2-1.fc32                          @updates                                    
qt5-qtgraphicaleffects.x86_64                      5.14.2-1.fc32                          @updates                                    
qt5-qtimageformats.x86_64                          5.14.2-1.fc32                          @updates                                    
qt5-qtlocation.x86_64                              5.14.2-2.fc32                          @updates                                    
qt5-qtmultimedia.x86_64                            5.14.2-1.fc32                          @updates                                    
qt5-qtquickcontrols.x86_64                         5.14.2-1.fc32                          @updates                                    
qt5-qtquickcontrols2.x86_64                        5.14.2-1.fc32                          @updates                                    
qt5-qtscript.x86_64                                5.14.2-1.fc32                          @updates                                    
qt5-qtsensors.x86_64                               5.14.2-1.fc32                          @updates                                    
qt5-qtserialport.x86_64                            5.14.2-1.fc32                          @updates                                    
qt5-qtsvg.x86_64                                   5.14.2-1.fc32                          @updates                                    
qt5-qttools.x86_64                                 5.14.2-1.fc32                          @updates                                    
qt5-qttools-common.noarch                          5.14.2-1.fc32                          @updates                                    
qt5-qttools-libs-designer.x86_64                   5.14.2-1.fc32                          @updates                                    
qt5-qtwayland.x86_64                               5.14.2-3.fc32                          @updates                                    
qt5-qtwebchannel.x86_64                            5.14.2-1.fc32                          @updates                                    
qt5-qtwebengine.x86_64                             5.14.2-2.fc32                          @updates                                    
qt5-qtwebengine-freeworld.x86_64                   5.14.2-1.fc32                          @rpmfusion-free-updates                     
qt5-qtwebkit.x86_64                                5.212.0-0.46.alpha4.fc32               @updates                                    
qt5-qtwebsockets.x86_64                            5.14.2-1.fc32                          @updates                                    
qt5-qtx11extras.x86_64                             5.14.2-1.fc32                          @updates                                    
qt5-qtxmlpatterns.x86_64                           5.14.2-1.fc32                          @updates                                    
qt5-srpm-macros.noarch                             5.14.2-3.fc32                          @updates

Down below my system:

OS: Fedora release 32 (Thirty Two) x86_64
Host: HP Laptop 15-db0xxx
Kernel: 5.7.10-201.fc32.x86_64
Uptime: 45 mins
Packages: 2135 (rpm), 8 (flatpak)
Shell: bash 5.0.17

Thanks in advance.