How to Install FUSE on Fedora 33

Hi there,

There are certain App Image’s that wont run unless I install FUSE.

I am running the lastest version of Fedora 33 on a Lenovo X1 Carbon.

I am trying to install FUSE., however when i goto here.

the instructions are unclear for Fedora/RHEL to me at least.

I am not entirely sure what FUSE is either as all the other app images I run dont need this dependency.

AppImages require FUSE to run. Filesystem in Userspace (FUSE) is a system that lets non-root users mount filesystems.

Might be that your user is in the “wheel” group, alias you are a root user ?

FUSE is installed by default and should be run out of the box:

$ sudo dnf list installed "*fuse*"
Installed Packages
fuse-common.x86_64                  3.9.4-1.fc33                @fedora         
fuse-libs.x86_64                    2.9.9-10.fc33               @fedora         
fuse-overlayfs.x86_64               1.4.0-1.fc33                @updates-testing
fuse3.x86_64                        3.9.4-1.fc33                @fedora         
fuse3-libs.x86_64                   3.9.4-1.fc33                @fedora         

If you need a particular subpackage for a filesystem, e.g. mounting remote directories over ssh:

sudo dnf install fuse-sshfs

Hi there,

I am logged as the admin over the system, trying to run the appimage file in the GUI not terminal.

I ran some updates and now the app runs, thats wierd

Hi thanks a lot,

Actually for some reason its working now after I ran some updates.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.