How to install AMD drivers on Fedora?

The question is in the title, " How to install AMD drivers on Fedora?" because I have no idea what to do, and I want to play games on my gnome, so ya :smiley:

Graphics Card Model: AMD Mobility Radeon HD 5470 Series

The default generic driver works well with AMD Radeon cards. It’s usually only people with Nvidia cards that need to install additional graphics drivers.


   Hi @orikindspirit.  In case of troubles with the graphics, use lspci -v to check if the card’s “Kernel driver in use” is a new driver amdgpu instead of the old one called radeon.

1 Like

Okay, lets say someone (me) built a new machine using a Radeon RX 5600 XT card and loaded Fedora 32. There are two monitors connected to the Radeon card. Only one display is functioning. The lspci -v identifies the correct video card and also says the kernel module is “amdgpu”. In the Settings dialog on the Displays tab it says “Unknown Display” and on the About tab it says the Graphics is “llvmpipe (LLVM 10.0.0, 256 bits)”. Any idea’s what to do to get both monitors working and hopefully recognized? I have been wrestling with this for a week now and am about at my whits end. Been to lots of forums and asked about this but I never get any answer. It is quite frustrating.

Thanks for any help!

I have installed xorg-x11-drv-amdgpu with dnf but when I check with lspci -v I get radeon as kernel module.

03:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cypress XT [Radeon HD 5870] (prog-if 00 [VGA controller])
	Subsystem: ASUSTeK Computer Inc. Device 0346
	Flags: bus master, fast devsel, latency 0, IRQ 11
	Memory at e0000000 (64-bit, prefetchable) [size=256M]
	Memory at fb7c0000 (64-bit, non-prefetchable) [size=128K]
	I/O ports at de00 [size=256]
	Expansion ROM at 000c0000 [virtual] [disabled] [size=128K]
	Capabilities: [50] Power Management version 3
	Capabilities: [58] Express Legacy Endpoint, MSI 00
	Capabilities: [a0] MSI: Enable- Count=1/1 Maskable- 64bit+
	Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
	Capabilities: [150] Advanced Error Reporting
	Kernel modules: radeon

For the time being I´m using nomodeset in my kernel parameters to get anything displayed. If I don’t use nomodeset my screen blanks (monitor goes to sleep) after grub.

How do I force Fedora to use amdgpu? Or, am I using the wrong driver for my card, because my card is too old?

@orikindspirit If you’re still looking for a solution. I have solved it by adding radeon.dpm=0 to the kernel command line in GRUB. It might work for you as well as we both have a card from the HD 5800 series.

To make it permanent add this parameter at the end of line kernelopts= in file /boot/grub2/grubenv

1 Like

BTW, this is a really great article that worked for me on F37!!!

EDIT: HIP does not work in Blender on my RDNA1 card still. Being able to install drivers on Fedora won’t fix the drivers themselves. :frowning:

1 Like

Please do not resurrect threads that have been necro for more than 2 years. Both software and hardware in fedora as it exists today are usually no longer relevant for the majority of users with those old discussions.