How to generate grub menu on FSB30?

Hi, there.

A few days back I changed from Fedora Silverblue to Fedora Workstation and now I’m back again to Fedora Silverblue 30.

I noticed an error message on my screen at the time of loading and it was "error ../../grub-core/commands/test.c:436:false". Cause I’ve legacy BIOS installation.

I also tried out this comment 44 and it didn’t work at all.

The bug is reported on Bugzilla https://bugzilla.redhat.com/show_bug.cgi?id=1688643 and https://bugzilla.redhat.com/show_bug.cgi?id=1699761.

On this page https://bugzilla.redhat.com/show_bug.cgi?id=1699761, (read comments 63,64) I executed command from comment 63 ‘grub2-install /dev/sda/’.

On rebooting again there error message was not there and also no grub menu.

Any ideas on how to generate or restore the grub menu?

Thanks.

“error …/…/grub-core/commands/test.c:436:false”`
[/quote] Same error here, but I’m using UEFI.

Look at comment number 11 at https://bugzilla.redhat.com/show_bug.cgi?id=1699761 that worked for me.

Gordy.

grub2-install /dev/sda worked fine for me, as I don’t use UEFI.

So checking if you booted with EFI or not is essential.
If efi is not listed (as below), then you are on a BIOS-based machine:

# ls /sys/firmware/
acpi  dmi  memmap

Another way might be seeing where grub.cfg is located.
In my case I have only /boot/grub2/grub.cfg and I don’t have /boot/efi/EFI/fedora/grub.cfg.

@yesiamabdul you can try following the instructions for UEFI on Reinstalling GRUB 2 section on Fedora documentation.