How to fix yum. I can run 'yum install ' or 'yum upgrade 'after lastest system upgrade

This sounds like a solution for OPs local RPM problem. The correct solution would be to have them declare dependencies correctly (report to devs) and be in a package repo.

Installing local packages on a nonstable system is a total pain, and also insecure as those packages are not cryptographically verified (so check the origin very well!)

I have seen similar comments in the past, and IIRC it was related to the user having installed nvidia drivers from a different 3rd party repo. (Possibly INTTF, negativo17, or the like.)

1 Like

Just remember that dnf4 and dnf5 use distinct databases, that could cause some weird problems