How to fix double docks in fedora36?

So I just updated my fedora35 to fedora36 and I encountered this issue.

I don’t know what’s wrong, I already tried to uninstall dash to dock extension but it doesnt fix the issue.

Please create a new user and test if you get the same behavior while log in with the new user.

If no, you have something incompatible in your config.

Can be that the mentioned extension is not Gnome 42 compatible yet or invalid settings you inherit from F35

You might have to reboot after de-installing the extension dash to dock to overwrite new settings or so.