How to fileshare with MacBook Air,

I am using fedora on a Lenovo AIO A6 I also have a MacBook Air that shows up on the “other places” but cannot get it to mount, nor will it work in Filezilla. ALL SHARING BUTTONS ARE ON on the Mac, fileshare is on. Fedora can “see” the Mac, but cannot mount or open the share. SSH on Terminal doesn’t work either.
Any suggestions?

ssh won’t work unless the destination is running the sshd daemon and the firewall on that machine allows access to port 22. Similarly file sharing requires the firewall to allow access as well as permissions and proper protocols.

Please provide more details of exactly what you are trying on both sides, including protocols being used, OS on each device, firewall configs, etc.

All we know at present is lenovo with fedora, macbook air, and connections are failing.

This is a guide on how to ask ‘smart’ questions that are easier to answer.

1 Like

MacBookAir M1 processor Ventura OS. all file sharing options are on/active.

file sharing is “on” firewall is set open for port 22 on both computers.
Lenovo AIO AMD A6 processor running Fedora:ID=fedora VERSION_ID=37 PLATFORM_ID=“platform:f37”
PRETTY_NAME=“Fedora Linux 37 (Workstation Edition)”
have used terminal with ssh command and ip address. fails to connect.

Filezilla both from MacBook to Lenovo and Lenovo to MacBook using ip, user name and password, cannot connect.

MAC appears in Home/other places on Fedora, but will not mount or open.

Are you getting selinux errors that are blocking access. That can be checked by looking at journalctl -f in one terminal then attempting to access the share and watching what is logged. It also can be checked by using sudo setenforce 0 to put selinux into permissive mode so it does not actively block the connection.

File sharing and ssh are apples and oranges. Different protocols and different security levels.

For ssh to connect it must have a compatible ssh daemon listening for connection on the remote end. Fedora enables connections incoming with systemctl enable sshd.service then systemctl start sshd.service, after which it will allow incoming ssh connections on port 22. I don’t know the commands to enable the same on the mac.

It also must have a valid username to connect to on the server. For my host named eagle, with the ip address in the /etc/hosts file on my workstation I can connect with ssh user@eagle and when it connects it prompts for the password to complete the connection. I always have sshd running on each of my machines for ease of connections.

Thanks for getting back to me. I will try the command line commands and see wha happens. Mac has s firewall gui dialog that is set to open firewall on my home network only. Mac is a little more secretive on command line use than linux.

Some organizations encourage file sharing via sftp security for security reasons. Fedora Files will connect to sftp servers. See: Using sftp for remote file transfer on macOS. This site has pages for rdp, ssh, and more for macOS users. Many Universities have similar documentation.

Thanks for the information, this looks like a good site for learning how to do this.