How to enable 'Tap to click' during the setup after booting the brand new installed Fedora Workstation 38?

Hello. Already when running Fedora Workstation Live 38, I’ve noticed that the mouse pointer can be moved with the touchpad though, but ‘Tap to click’ with the touchpad wasn’t possible. My touchpad’s got no buttons for mouse clicks. There’s only the pad itself. I’ve been able to struggle through the installation of Fedora with the tab and arrow and enter keys, thinking, an automatic update would solve the problem. When the installation was finished and after a reboot of the newly installed OS, I’m at the wifi selection dialogue. Now the tab and arrow keys no longer work, but moving the mouse pointer still does.

Regarding my problem, I found this website: How to enable touchpad click :: Fedora Docs

I learned that Gnome is the standard desktop environment of Fedora Workstation from this website: Switching desktop environments :: Fedora Docs

That’s what I’d probably need to do Click, drag, or scroll with the touchpad, however, there’s no ‘Activities’ button on the top left of my screen. Pressing the windows key doesn’t display the ‘Activities’ menu either.

The only button I’ve got is the speaker and battery on the top right of the screen which is inaccessible. I’m completely stuck.

Is it possible to make mouse clicks with the touchpad work?

What does happen when you press the Super key (aka the Windows key)? Can you post a photo of what you see on the desktop (a screenshot might be difficult given the problem, so a photo with your phone is fine)?

Nothing happens when the super key is pressed, literally.

(I blackened the available wifi networks.)
Meanwhile, the system was automatically set to suspend mode. I noticed that it’s possible to wake it up with the arrow down key, so at least this key works in this context. Furthermore I noticed that when the mouse pointer is moved over the wifi networks with the touchpad, the focus is put on the specific network because it gets highlighted. ‘Only’ left clicks and right clicks with the touchpad don’t work. I cannot go on with the installation.

Moving/pushing the mouse into the top left “hot” corner is another way to get the “activities” overlay, along with pressing the Super key: Visual overview of GNOME

Somehow your screenshot doesn’t look right. Normally there is also a time and calendar function at the center of the top bar as well:

One way or another, you need to get into the Settings and configure the Touchpad to allow Tap to Click. I don’t know why it isn’t enabled by default. It’s really annoying and one of the first things I do when dealing with a Live CD or new installation.

Aside from all that, are you sure there are no left or right click buttons on your laptop, such as being able to “click” the left or right sides of the touchpad itself? The omission of any button function would be surprising and unusual.

I agree.
Every laptop I have used with a touchpad has had the lower edge of the touchpad (~3/8 inch) such that pressing on the left or right activates the mouse clicks. Mouse movement is done on the rest of the touchpad IME.

Ah, I see. I believe that that is the post-installation setup tour, during which the activities view is not available. Honestly, I really don’t know if there’s a way past that if you can’t click on anything. A cheap USB mouse is probably your best option here.

1 Like

I pressed on the left on the lower edge of the touchpad and double pressed on the left on the lower edge, too. Both didn’t activate the mouse clicks.

What does IME mean?

I moved my mouse pointer to the top-left hot corner and tried again by pressing the super key according to Visual overview of GNOME. Both not successful.

I moved the mouse pointer onto my wifi network and ‘clicked’ the left side of the touchpad and double ‘clicked’ the left side, too. Both didn’t work.

As mentioned, the activities overlay may be unavailable because you’re in the setup tour. Maybe you can exit that with ESC or Alt-F4 or Alt-Q, and then try Super or the upper left corner to get to settings.

If all else fails, then time to plug in a mouse.

Btw, what is the model of your laptop? I still find it hard to believe that any truly lack the ability to click.

I don’t know what OP is using, but I know there at some models of HP Elitebook which don’t have any kind of physical click available for the touchpad, only tap-to-click. I don’t know if this is such a model specifically, but it looks like one of the ones I used to deal with in the past.

How can we get this to the GNOME people? This may become a big issue if people aren’t able to progress through the setup process with tap to click disabled by default


In My Experience.

I attached a Usb mouse and completed the installation. A software upgrade and a following restart didn’t automatically solve the problem. Only Activities>Show Apps (9 dots)>Settings>Mouse and Touchpad>Touchpad tab>Enabling ‘Tap to click’ solved the problem.

It would be great if ‘Tap to click’ is turned on by default.

This should probably be reported by a bug at so it can be triaged and forwarded as needed to the upstream developers. This seems a setting that would be very limiting if not set and very helpful if it is set.

As long as ‘Tap to click’ is not enabled by default, the only possibility that makes sense to enable it, is to connect a mouse.

But according to How to enable the mouse functions of the touchpad? - #17 by tomaszgasior,