How to do wildcard DNS?

I am trying to run OpenShift Local (aka crc), and in order to get the best experience, wildcard DNS resolution needs to work for the apps-crc.testing domain.

The general advice is to use dnsmasq, and I added the following configuration to /etc/dnsmasq.d:

$ cat /etc/dnsmasq.d/99-apps-crc-testing.conf 

However, general apps-crc.testing domains don’t resolve on my machine, only the ones defined in /etc/hosts resolve.

Did I miss something here?

sudo tee /etc/dnsmasq.d/custom.conf << EOF > /dev/null
sudo systemctl enable dnsmasq.service
sudo systemctl restart dnsmasq.service
sudo nmcli connection show
sudo nmcli connection modify CONNECTION \
    ipv4.ignore-auto-dns yes \
    ipv6.ignore-auto-dns yes \
    ipv4.dns \
    ipv6.dns ::1

Make sure that your dnsmasq instance does not conflict with systemd-resolved.