How to disable the emoji support altogether?

‘Emojis’ are, in my view, are mostly used for non-constructive purposes, especially on social platforms pulling more casual crowds. There are descriptive Unicode characters such as the arrows → ← and check mark ✓ which more or less fill my own needs at the time, and they can conveniently be typed with the Compose key (<- / -> / v/, albeit the latter outputs √).

I assume that editing or removing a system font package is required. Websites may supply their own fonts (can be disabled in Firefox settings, ‘allow pages to choose their own fonts […]’) or use emoji-like “reaction images” which can generally be trivially blocked with uBlock Origin.

You :point_right::frowning_man::point_right: can’t :no_good_woman: disable support :smiley_cat: for :clap::gift: emoji :no_entry_sign::stuck_out_tongue_closed_eyes: any :clown_face: more :heavy_plus_sign: than :point_right::point_right: you :point_right:t2::person_frowning:t2: can :revolving_hearts: disable support :+1: for :u55b6: the character “a”.

However, :thinking: you :point_left: can :smiling_face: remove :x::no_entry_sign::pensive: all :smirk::100: emoji :joy: fonts:

dnf remove '*emoji*-fonts'

or blacklist fonts using :outbox_tray: fontconfig.

This post :envelope_with_arrow::memo::speech_balloon: was emojified using :selfie:

dnf remove '*emoji*-fonts'

Only the google-noto-emoji-color-fonts package appears to ship with Fedora Workstation (38).