How to delete Nouveau so I can install Nvidia driver

I would like to install the Nvidia Driver but understand I need to delete the Nouveau driver first. I’m a lightweight when it comes to this kind of stuff. I’ve seen a number of links on how to do this but they all involve creating a file etc. Can anyone put the process in layman’s terms? I’m using KDE Fedora on an ASUS laptop with an Intel and Nvidia GEForce MX 150. I have the Nvidia driver and am ready to go once I get rid of the Nouveau. Thanks in advance for the help

Hi @reno232

I think you should check the installation of your driver only trough the instructions provides for rpmfusion, this is the way to do a right installation in fedora.

The last driver 435.21 in the rpmfusion repo is supporting your GPU like you can check in this link (nvidia 435.21). Because the link of rpmfusion that does reference to the supported GPU is referred to the driver 390.x which is not supporting your GPU.

It is not complicate to do but you need take special attention to part that does reference to “special notes” In your case take special attention to “Secure boot” and “Optimus”. About the “wayland” part it is important if you are running kde with wayland but i think KDE fedora is running in X11, in anyway you can check it for yourself with a simple command in the terminal (look the post under):

The rpmfusion’s way is the more secure to do a right installation of the driver.



@reno232, to extend a bit @xtym’s answer, you do not need to delete nouveau driver first, rpmfusion’s packaged NVidia driver will disable nouveau.

It’s described in the how-to @xtym provided, though maybe not in a great detail.

There’s also this article in FedoraMagazine that goes into much more details, it can be good if you want to understand the process better:

It’s for older Fedora version, but the process itself isn’t different. I myself prefer to use rpmfusion’s how-to for installation, as @xtym suggested.

One more note. If you happen to have driver from NVidia’s site, I strongly advice against using it. Use rpmfusion’s packages instead, they are much better for a number of reasons. We’ve discussed these reasons here on Ask Fedora quite a few times already, you should be able to easily find these discussions if you’d like to do so.


Thanks for the help guys. Still a little complicated for a novice like me. I’ll have to grind it out with Nouveau until they get things fixed. I appreciate your efforts

Actually upon reflection, maybe I can do this. I guess my one hang up is it says " Finally, to ensure a successful reboot, set “WaylandEnable=false” in /etc/gdm/custom.conf". How do I get there to make the change as I don’t know how to get to that directory? Again, please forgive my ignorance, everything else seems pretty straight forward.

You are in kde spin so if i am not wrong you shouldn’t have this folder called gdm (Gnome Display Manager). Type in consola:


You will see something like it:

[jorge@fedora31 ~]$ loginctl
  2 1000 jorge seat0 tty2

1 sessions listed.

Now if you type in the console the command:

loginctl show-session <YOUR_SESSION_NUMBER> -p Type

note: <YOUR_SESSION_NUMBER> = it is the number of your session in mi case this value is 2, like you see here:

[jorge@fedora31 ~]$ loginctl show-session 2 -p Type

How you can see i am running Wayland because i am running gnome fedora, in you case you session type shouldn’t be wayland.

One time you did check that you are not running Wayland. You need do the rest of steps:

  • Disable secure boot (it has that be done trough the BIOS of your motherboard, you need see hpw do it before you try install the driver, if you feel not comfortable with the BIOS stuff look into internet: How disable secure boot in BIOS <your_model>.

  • Read again the information contained in the links indicated before, do sure that you dont miss something.



Upon running loginctl:
2 1000 Ted seat0

1 sessions listed.

loginctl show-session 2 -p Type

So, I take it I’m running x11 not Wayland.

Would I then need to do an x11=false command, or am I good to go with the install?

You don’t need do nothing about it. It is ok you are running x11 like it was waited in kde spin.

Don’t forget to disable secure boot in your Bios, it is very important and make sure that you understand every step in the links.

Thanks xtym. One last question, it says to " Login, connect to the internet, and open the software app. Click Add-ons> Hardware Drivers> NVIDIA Linux Graphics Driver> Install.". Given I am running KDE, I don’t have the software app, but Discover. As I go to Discover, I can’t find the NVIDIA driver anywhere. It seems to me as I tried this before in the Gnome setting, I was able to find it in the software app, but that’s not available in KDE. One of the other sites suggested running the program as root and /home/Ted/Downdloads/ but that did nothing. So, how do I start the program? Thanks again for all your time, it has been greatly appreciated

BTW, I downloaded and have it in my Downloads folder

I may have found my answer. Would I type the following to install?:

sudo dnf install akmod-nvidia # rhel/centos users can use kmod-nvidia instead
sudo dnf install xorg-x11-drv-nvidia-cuda #optional for cuda/nvdec/nvenc support
sudo dnf update -y

1 Like

sudo dnf install akmod-nvidia
sudo dnf update -y

Hi @reno232 lets go a bit more slow ok :sweat_smile: ?

First disable secure boot, don’t install nothing until you have disabled it. it is very important step than you are missing and is the first thing than you need to do.

I did disable it. I ran the above to no avail apparently. It never came up with the Nvidia install screen and I still can’t find it is Discover. How would I properly run the file in my downloads?

Meaning the file in my Downloads file

So, I tried installing from my downloads folder: sh at which point it opens the installer but says I need to run it as root. Running the same command line in root does nothing. How can I run this driver in root?

If you didn’t it rightly you will go probably at a black screen and you will have not access at your graphic session. Sure you do a backup to another disk /usb in case. Secure boot is a extremely important step and it need be disable because : “Secure Boot currently blocks the kernel from loading the NVIDIA driver. It must be disabled before booting the OS”.

This tip of installation you should avoid, the rpm fusion package is the right way because it is maintained and supported to fedora.

If you did disable secure boot and you are sure about that you did (if you aren’t, Don’t continue the following procedure):

Type in terminal the followed commands in order:

  1. First, open up a terminal, and update your package-manager (if you have not done so already), by running:

sudo dnf --refresh update

  1. Next, reboot with the simple command:


  1. Next, enable the NVIDIA driver repository:

sudo dnf config-manager --set-enabled rpmfusion-nonfree-nvidia-driver

  1. Then, reboot again


  1. After the reboot, verify the addition of the repository via the following command:

sudo dnf repository-packages rpmfusion-nonfree-nvidia-driver info

If several NVIDIA tools and their respective specs are loaded, then proceed to the next step. If not, you may have encountered an error when adding the new repository and you should give it another shot.

  1. Installation of driver:

sudo dnf install akmod-nvidia

Note: Please remember to wait after the RPM transaction ends, until the kmod get built. This can take up to 5 minutes on some systems.

  1. Update again:

sudo dnf update -y

  1. Then reboot:


If you did disable secure boot and follow the steps, you should have the nvidia driver rightly installed. Like indicated a lot of times don’t install the driver if you didn’t understand something or secure boot is not disable.


1 Like

Thanks again xtym. I followed your instructions to a tee. It seems as though installed fine. The problem is that Nouveau is still lurking in the background as I’m still getting Nouveau error messages on boot up. I suspect I need to disable Nouveau completely & in a way that the install program doesn’t fully.

Can you post the output of this command?

cat /proc/cmdline

1 Like

BOOT_IMAGE=(hd1,gpt2)/vmlinuz-5.3.8-300.fc31.x86_64 root=/dev/mapper/fedora_localhost–live-root ro resume=/dev/mapper/fedora_localhost–live-swap rhgb quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1