How to connect and work with SEAGATE Expansion 18 TB in fedora linux?

Hi guys, ive just bought SEAGATE Expansion 18 TB and i would like to work with this USB external drive in Linux as im in Windows.
The problem is: after lunching Fedora and opening the Nautilus or Gparted (or anything else that wirks with disks) connected disk dissapair in few minutes. :face_with_spiral_eyes:

Is anybody here, who can help me with connecting it pernamentelly? Its really crazy thing for me :expressionless:
Thx Guys. :slight_smile:

Hello @hoodas ,
Welcome to :fedora: !
I use an external Seagate BUP 4GB and it connects via usb. I leave it connected as it is where I backup to so it is always at /run/media/<username>/<volumename>, and it doesn’t disappear on me. I do not boot from it though, and I don’t dual boot my machine. If I need win stuff I use a VM, or my lone win10 laptop.

1 Like

Hello @jakfrost ,
Thank you for advice. I hope it will help maximally. :slight_smile:
Do you have idea, how to connect other dicts atumatically after system start?

Many years ago (like more than 12) o was playing with virtual machines to. I think, i found KVM/Quemu and it was interesting for me. I think, in that time it wasnt so perfect as it is now but … im not sure if i tried it (12 years agi ive been hit by car on crosswalk, got head damadged and lost longterm memory). In that times i was using Mandriva Linux.

So thats a reason i have many many many questions lol :smiley:

But thank you alot @jakfrost

Sorry if I’m going so far with explaining, but as this is a public forum I write it for beginners in general :wink:

Difference between Windows and Linux is in this case, that windows uses a drive letter for each partition while Linux is mounting it in your Filesystem with a mounting name.

In other words as @jakfrost mentioned it will automatically mount like /run/media/<username>/<volumename>

Probably you have to tell with which Desktop Environment you prefer to work? If you want to use a Gui.

If you are not scared about the terminal you can make your own moint-points as you like them.
To check the name as Linux sees your partition alias block device you can do this with


sda      8:0    0 931.5G  0 disk 
├─sda1   8:1    0   600M  0 part /boot/efi
├─sda3   8:3    0 585.9G  0 part /mnt/fedy36
├─sda4   8:4    0     1K  0 part 
├─sda5   8:5    0     1G  0 part /boot
└─sda6   8:6    0   344G  0 part /home
zram0  252:0    0     8G  0 disk [SWAP]

The physical drive you find in the /dev folder

ls /dev/sd*
/dev/sda  /dev/sda1  /dev/sda3  /dev/sda4  /dev/sda5  /dev/sda6

sda is the drive it selves
and sda1 to sda6 are the partitions in my case.

You see that I do have a Mountpoint like /mnt/fedy36

First I had to create a folder named fedy36 in /mnt/fedy36 and afterwards I mounted it like
sudo mount /dev/sda3 /mnt/fedy36

If it disappears in gparted I bet you have a problem with the power supply or the usb cable.

1 Like

Wow, thank you @ilikelinux,
ill definitelly try it but definitelly thank you. Its another thing, that bothers me a little too and im looking for solution. I found one at Youtube but commands are not for new Fedora version.

Thanks alot L.S. :slight_smile:

1 Like

Well, it looks like i have small problem with fiding disk again …
Im sorry, but i guess, i need small … emmm “step by step” manual or … may i ask for small chat help? :expressionless:

first from the command line run ls /dev/sd*
Then plug in the external drive and after a few seconds repeat the ls /dev/sd* command.
The device being seen and configured should also show up when you run dmesg just after connecting it.

The difference shown in the listing of the /dev/sd* devices should be the new device you just connected. If this does not show a change then the system is not seeing the drive at all. Without the system seeing and configuring a device none of the apps are able to access it.

If the drive is HDD or SSD this should be correct whether connected by USB or directly by SATA. If the device is nvme this may not show as sd* but instead may be seen as /dev/nvme*. The dmesg output should show it either way.

Whatever You do in Windows with this storage and would like to do in Linux is not clear. It’s external USB drive. Since it’s 18 TB it’s probably “classic” hard drive (“spinning rust”). How do You use it? For backups? Additional storage? If that is the case, don’t keep it plugged untill You log in to Your Gnome session. Also check if USB cable is properly plugged. (I have issues with my USB scanner which are handled with a little force on cable side.) You can see a lot of info about what is going on with system and devices if You start a “journalctl” command in terminal. “lournalctl -f” will keep displaying most up to time info. I dare to suggest reading “man 1 journalctl” for more info about options.

Hello @hoodas ,
I do not see your 18TB Seagate listed. Do you plug it into the same usb port every time (not that it makes a difference to automounting) it can be a bad port, try another USB port and test again if the drive disappears. Does it plug into the wall with a wall transformer to get power? If it doesn’t you may need to get an external usb powered hub to provide sufficient power/keep it from sleeping (which some of your drives show they are doing). Is it a spinning disk or an SSD?

1 Like

Yes, that’s also important.

Hi @jakfrost,

I dont see it too. The real problem that i have in linux is, after debooting or starting my Fedora, i culd for small moment see other partitions but by clicking on it displayed problems with connecting to.
Than partitions disappeared. I cant find then iven in Terminal. My problem is little complicated and it would be amazing to get step by step instructions or … the best would be to solve it with someone online :slight_smile:

The easiest way to get that may be at the matrix chat channel for workstation found at Be patient there since you are waiting for someone to be online, but there are usually a number of active users form the workstation SiG whenever I login . Communication at this site is very asynchronous.

Just as an aside note. I have gotten used to never being root on my system, it is far more secure and prevents (me) from inadvertently doing something to break it. Sudo has worked well for me for over a decade.

Having that device fail to be configured points to a couple of possible failure points.

usb cable
usb interface within the enclosure (these have been found numerous times)
no or inadequate power to the device enclosure (often causing symptoms similar to what you posted above)

Less frequently, but possible the following

usb port on the pc (try a different port)
drive inside the enclosure.

Occasionally it has been found that a usb3 device may not configure when plugged into a usb2 port, and vice versa. Or that a cable that otherwise seems perfectly fine may not support usb3 connections.

Hi @computersavvy,
Its little complicated and weird because usb cable is connected and it works in Windows with no problem but in the moment i restart and switch to Fedora, it doesnt work (well, respectivelly it works for like maybe 2 minutes by way, i can see device but i cant access the content).

  • usb port on the pc (try a different port) → i tried different ports and other stuff too. In technical way its connected directly to the mainboard.
  • USB2 → yup, its USB3 ports. :expressionless: |

The only thing hardware related aside from the USB port would be the power supply itself (I think the Seagate Expansion series uses an 18W wall wart). If it is fine in Windows all the time and not fine in Linux sometimes, then it will definitely be configuration related as @computersavvy suggests. I can’t find any issues with that particular drive, though it does not mention linux as supported in device requirements. So you could try making a permanent mount point for it in /etc/fstab that mounts the device /dev/sdx at /desired/mount/point. But I think you would need to modify UDEV rules to prevent unintended behaviour, just not sure about that.

From a tiny footnote in Seagate Expanson Desktop Specifications:

Reformatting may be required for use with Time Machine

This suggests the drive already has some sort of partitions with vednor software. The drive recognizes Windows or macOS and does configuration when first connected. In the past I have connected such drives to Windows or macOS and used native tools to create a partition for use with linux, leaving a small partition with the vendor’s utilities and documentation.