How to add an application to the 'show applications'?

I have downloaded MultiMC and I would like to launch it easily through the ‘show applications’.

How can I do that?

1 Like

1 Like

Exec=application The command that starts this application from a shell. It can have arguments.

What do I put here?

I went through the .desktop files for the other applications in the menu and I realized that the ‘Exec’ line has commands that can run through the terminal and ‘MultiMC’ is not a command that works. How do I find out which command runs it?

Specify the full path.

I can’t paste files in the applications directory for some reason?

It says ‘permissions do not allow pasting of files in this directory’

also when I try to put the full path in the teminal which is home/MultiMC/bin/MultiMC
it just says no such file or directory

An absolute path in Linux always starts with a slash:

See also if you have permission-related issues:

1 Like

added the slash at the start and no change in the result.

and I went through the page for chmod and chown thrice and looked it up online and I have no clue how I’m supposed to use this.

edit: how do I even have permission issues? I installed the distro and my account is the only one here?

Works for me:

tar -z -x -f mmc-stable-lin64.tar.gz 
tee ~/.local/share/applications/mmc.desktop << EOF > /dev/null
[Desktop Entry]

Try this by Exec:
gnome-terminal --full-screen --window -e /path/to/your/script
This will open a terminal window.

I think I finally figured out what was happening. The file explorer showed the folder where I had stored the MultiMC folder as the ‘Home’ Folder but when I right clicked and checked the properties I noticed the location said Home/Destinyblade. so I tried out - /home/Destinyblade/MultiMC/bin/MultiMC in the terminal and that worked

I still don’t understand the permissions thing though. and I think this permissions issue is showing up in another application where I’m trying to install a theme for LibreOffice and the permissions for the folder where themes go is set to root. Don’t know if I should open a separate thread for that or continue in this

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.