How to add a firmware file manually to Fedora 35?

I have certain laptop, for which Linux firmware drivers are not available from the manufacturer (they never make them), but available in github. It is a .fw file. In Arch, Ubuntu or OpenSuse, that file can be pasted in /lib/firmware and once rebooted, it works. But, in Fedora 35, the firmware files are xz archived. I archived the .fw files and pasted it in /lib/firmware, and rebooted Fedora 35, but that didn’t work. How do I get Fedora to see this file?

1 Like

I have several .fw files in /usr/lib/firmware.
Have you tried putting the .fw file there?
There are also some mfgr specific directories that have multiple files and some contain .fw files. Not all firmware in fedora 35 is .xz files, but some is .fw, .bin, and others.

I also did a “find / -name firmware” search and got several different locations for firmware. You may need to do a similar search and find out exactly where the file needs to be placed and in what format .

We can’t give you better info since you refused to tell us the brand/model of the laptop so no one can tell if they have ever dealt with that particular device.

Try running sudo dracut -f to rebuild initramfs after putting the files in /usr/lib/firmware. This is needed for some (all?) firmware to get loaded. Worked for me when manually downgrading firmware for my GPU.

xz *.fw
sudo cp *.xz /usr/lib/firmware
sudo restorecon -R /usr/lib/firmware
1 Like

Thanks guys, I’ll try again. @ludwigd @vgaetera
@computersavvy I put the .fw file without xz archiving too. The .fw file should go inside a folder named silead. This is for touchscreen gestures. /lib/firmware/silead/xxx.fw.xz in case of Fedora. In other distros, it was /lib/firmware/silead/xxx.fw

1 Like