How do you access grub2 release info?

I tried the following command

$ grub2-install -Vv
grub2-install (GRUB) 2.06

(AKA grub2-install --version --verbose), but I need to make sure the relaase number is 47.fc36, which fixed this bug on my dual boot system.

I’ve tried looking at and grepping the help page for grub2-install but cant find anything that tells me the release version.

The number you are talking about is the version (release) of the RPM.
So. grub2-2.06-47.fc36
grub2 is the name of the software
2.06 is the version of the packaged software
47 is the version of the RPM package

So the RPM can be updated, but the packaged software version can remain the same as before.

Then, in order to know which package version you have installed you have to query the RPM database.
For example rpm -q grub2

Better: rpm -qa 'grub2*


Better than better :slight_smile: rpm -qa 'grub2*'


Nice thank for the info. I’m new to Fedora so still learning :slight_smile:

1 Like

Note that the fedora docs here tells you that grub2-install is for use on bios based machines, not for uefi based machines.

1 Like

Oh ok I didn’t know that thanks!

Also, grub2-install will terminate with an error if you try it on UEFI systems.