How do I get xmonad to work?

I followed the instructions on the xmonad install page.

I installed dependencies, downloaded xmonad source, built & installed it using stack, and got to here:


/etc/X11/xinit/xinitrc runs ~/.Xclients, so you probably want to put exec xmonad there (don’t forget the shebang and chmod). Like in Debian, this can be overridden by having a completely custom ~/.xinitrc or passing arguments to startx/xinit.

I did that also (or thought I did).

I created an ~/.Xclients file, ran chmod +x on it, and inserted these lines:

exec xmonad 

But when I look for xmonad as an option on the login screen - it’s not there. And when I boot into the other options, it’s just gnome.

What should I do?

In order to see it on the login screen, you need to have a .desktop file for xmonad in the /usr/share/xsessions/ directory. Why don’t you install it from the Fedora’s repos with sudo dnf install xmonad? That should place the xmonad option on the login screen.