How do I disable automatic suspend in Fedora 36?

I have installed the Fedora I3 spin which doesn’t feature any DE and I was wondering how I could stop my screen from going to sleep after 10 minutes (really annoying when playing games with a controller).
I’ve tried masking via systemctl and editing /etc/systemd/sleep.conf but to no avail.

Under the gnome settings panel → privacy → screen lock you can set the timeout. 1 to 25 minutes or never.

Maybe xset s noblank or xset -dpms. Use xset q to query the current settings.

You might need unmasked in order for sleep.conf to get parsed.

As I said, I do not use any desktop environment.

Thanks, I installed xset and wrote the command xset s off and it seems to do the trick

1 Like

Thanks, I worked fine with the latest version too. From Fedora 40.