Help me about this autoremove request after upgrade from Fedora 30 to 32

Hi dears. I finished system upgrading from Fedora 30 to 32. System upgrade achieved from within tty terminal. The process was very very very smooth without any error.

After login to my new Fedora 32, I run “sudo dnf autoremove” & result was as following:

> sudo dnf autoremove 
> Last metadata expiration check: 2:32:28 ago on Sun 31 May 2020 03:08:12 PM GMT.
> Dependencies resolved.
> ======================================================================================================================================================
>  Package                                        Architecture             Version                                     Repository                  Size
> ======================================================================================================================================================
> Removing:
>  GeoIP                                          x86_64                   1.6.12-6.fc31                               @fedora                    359 k
>  GraphicsMagick                                 x86_64                   1.3.34-2.fc32                               @fedora                    4.9 M
>  argyllcms                                      x86_64                   1.9.2-8.fc31                                @fedora                    7.7 M
>  colord-gtk                                     x86_64                   0.2.0-3.fc32                                @fedora                     75 k
>  compat-wxGTK3-gtk2                             x86_64                   3.0.4-13.fc32                               @fedora                     17 M
>  comps-extras                                   noarch                   24-7.fc32                                   @fedora                     83 k
>  epiphany-runtime                               x86_64                   1:3.36.1-1.fc32                             @fedora                    3.9 M
>  fipscheck                                      x86_64                   1.5.0-8.fc32                                @fedora                     49 k
>  fipscheck-lib                                  x86_64                   1.5.0-8.fc32                                @fedora                     16 k
>  gdbm                                           x86_64                   1:1.18.1-3.fc32                             @fedora                    406 k
>  google-droid-sans-mono-fonts                   noarch                   20200215-3.fc32                             @fedora                    121 k
>  hwloc-libs                                     x86_64                   2.0.4-3.fc32                                @fedora                    2.8 M
>  jimtcl                                         x86_64                   0.78-4.fc32                                 @fedora                    763 k
>  lcms-libs                                      x86_64                   1.19-29.fc32                                @updates                   238 k
>  libXxf86misc                                   x86_64                   1.0.4-6.fc32                                @fedora                     35 k
>  libatomic_ops                                  x86_64                   7.6.10-4.fc32                               @fedora                     85 k
>  libclc                                         x86_64                   0.2.0-17.git9f6204e.fc32                    @fedora                     57 M
>  libglade2                                      x86_64                   2.6.4-23.fc32                               @fedora                    161 k
>  libgnome-keyring                               x86_64                   3.12.0-19.fc32                              @fedora                    307 k
>  liboauth                                       x86_64                   1.0.3-14.fc32                               @fedora                     49 k
>  mesa-libOpenCL                                 x86_64                   20.0.7-1.fc32                               @updates                   1.1 M
>  opencl-filesystem                              noarch                   1.0-11.fc32                                 @fedora                      0  
>  pocl                                           x86_64                   1.5-2.fc32                                  @fedora                     51 M
>  pygtk2-libglade                                x86_64                   2.24.0-29.fc32                              @fedora                     33 k
>  python2-setuptools                             noarch                   41.2.0-2.fc32                               @fedora                    3.1 M
>  python2-six                                    noarch                   1.14.0-2.fc32                               @fedora                    109 k
>  python3-cssselect                              noarch                   0.9.2-14.fc32                               @fedora                    140 k
>  python3-html5lib                               noarch                   1:1.0.1-8.fc32                              @fedora                    1.1 M
>  sbc                                            x86_64                   1.4-5.fc32                                  @fedora                    159 k
>  systemd-bootchart                              x86_64                   233-6.fc32                                  @fedora                    155 k
>  tpm2-abrmd                                     x86_64                   2.3.1-2.fc32                                @fedora                    328 k
>  tpm2-tools                                     x86_64                   4.1-2.fc32                                  @fedora                    5.1 M
> Transaction Summary
> ======================================================================================================================================================
> Remove  32 Packages
> Freed space: 159 M
> Is this ok [y/N]: N
> Operation aborted.

Is removal of those packages safe ? What about “systemd-bootchart” package ?? I’m afraid from breaking my system. Before upgrading from Fedora 30 to 32 & run “sudo dnf upgrade --refresh” & then I run “sudo dnf autoremove” & result of “sudo dnf autoremove” was NO THING TO REMOVED !

Any help is appreciated !
Thank you.

I don’t know that removal is necessary. I upgraded from F31 to F32 and the autoremove option shows 27 packages the same. What I suspect is that package updates caused those packages to be no longer required as dependencies so it may (or may not) be safe to remove them. I chose to leave them since the space required is small and I did not want to do the research to verify they were not needed.

# dnf info systemd-bootchart
    Last metadata expiration check: 2:53:39 ago on Sun 31 May 2020 10:33:43 AM MDT.
    Installed Packages
    Name         : systemd-bootchart
    Version      : 233
    Release      : 6.fc32
    Architecture : x86_64
    Size         : 155 k
    Source       : systemd-bootchart-233-6.fc32.src.rpm
    Repository   : @System
    From repo    : fedora
    Summary      : Boot performance graphing tool
    URL          :
    License      : GPLv2+ and LGPLv2+
    Description  : This package provides a binary which can be started during boot
                 : early boot to capture informations about processes and services
                 : launched during bootup. Resource utilization and process
                 : information are collected during the boot process and are later
                 : rendered in an SVG chart. The timings for each services are
                 : displayed separately.

You choose for each one if needed or not. The systemd-bootchart package is not critical by any means.

1 Like

Removing them is safe in the sense that no other package on your system requires these any longer, so it won’t break the parts of the system under the control of package management.

If you’ve installed software directly rather than via package management, or have written scripts or similar, that software might require some of those packages, but I guess you would know if that were the case.

If you want to for whatever reason keep some of those packages and want to prevent them from being autoremoved, you can use

dnf mark install <package>

which flags the package as explicitly installed without doing anything else.
This can be undone via

dnf mark remove <package>

which will mark it as being installed as a dependency, and cause it to once again be picked up by dnf autoremove.

Hi dear. Thank you for explanation.
However, it seem that I’m unlucky because I did not remove those packages just after reading your replay.
I’m delay autoremove till today. But before tried autoremove I updated my system & received an update for DNF, YUM, systemd, …
After receiving this update I run autoremove. But this time show me 2 additional packages to be removed. So instead of 32 package, now I have 34 packages. But do you know what are the additional 2 packages? They are the following:

kernel x86_64 5.6.14-300.fc32 @updates 0
kernel x86_64 5.6.15-300.fc32 @updates 0

But I’m already on kernel version 5.7.15-300.fc32 (the most recent received on my system till now) ! & what about the size 0 for kernel package ??

What I have to do now ? I will file a bug for RedHat Bugzilla …

For logistical reasons, the kernel package is actually a meta-package that pulls in the actual kernel packages (kernel-core & kernel-modules) through dependencies, so that is why it has size 0. That is totally normal.

However, dnf autoremove should not remove those kernels - they should be marked as userinstalled and thus excluded. 5.6.15 is the current kernel, so removing that would definitely be a … problem.

This could be this bug. You should check if they’re marked as user-installed using

dnf repoquery --userinstalled 'kernel*'

This should list kernel, kernel-core & kernel-modules.

Here's how it looks like on my system
$ dnf repoquery --userinstalled 'kernel*'

If not, mark them as explicitly installed using

dnf mark install kernel kernel-core kernel-modules

In any case, open a bug, this should not happen. It could just be the bug I linked above hitting you belatedly, but if that were the case, I would have expected this to appear after the initial update to F32.

Hi. I run "sudo dnf repoquery --userinstalled ‘kernel*’ & the output was a disaster ! Look bellow:

sudo dnf repoquery --userinstalled ‘kernel*’

I, then, run: “$ dnf info kernel-headers” & output was:

$ dnf info kernel-headers
Last metadata expiration check: 4:54:23 ago on Fri 05 Jun 2020 07:31:49 AM GMT.
Installed Packages
Name : kernel-headers
Version : 5.6.11
Release : 300.fc32
Architecture : x86_64
Size : 4.9 M
Source : kernel-headers-5.6.11-300.fc32.src.rpm
Repository : @System
From repo : updates
Summary : Header files for the Linux kernel for use by glibc
License : GPLv2
Description : Kernel-headers includes the C header files that specify the
: interface between the Linux kernel and userspace libraries and
: programs. The header files define structures and constants that
: are needed for building most standard programs and are also
: needed for rebuilding the glibc package.

What is this ?? What I have to do know ?? I feel that I’m in big problem …

By the way, please when you give me command instructions, set “sudo” or # before command if it need to be run as root & $ before command if it should be run as non-root. This is necessary to avoid error.

I noticed that dnf repoquery --userinstalled ‘kernel*’ can be run as root & non-root. What is more correct?

Kindly notice that version of “kernel-headers” is 5.6.11 while kernels on my system are 5.6.14 & 5.6.15 ! Is this normal or it reflect a big fatal mistake ?

Don’t worry, everything is fine.

kernel-headers 5.6.11 is the latest available version on F32, so that is what you have. That package is typically needed in order to compile programs on your computer, it is not involved in the running of the system.

The lack of other output simply means that the error is what we suspected: dnf mislabeled the kernel packages (most likely due to the bug I linked). If you mark those as deliberately installed, everything should be fine again:

sudo dnf mark install kernel kernel-core kernel-modules

After that, sudo dnf autoremove should no longer list the kernel package as removable, and ‘kernel/kernel-core/kernel-modules’ should be listed in the output of sudo dnf repoquery --userinstalled ‘kernel*’.

Regarding sudo dnf/dnf: All commands that don’t actually change your system, like search, info, repoquery - basically all informational commands, can be run with or without sudo, the result will be the same. Anything that actually does anything needs to be run as root/with sudo - if you do it without, dnf will simply tell you to try again with sudo.

Issue is fixed by following your recommended solution. Thank you too much for your kind support !
I thought that I replay with my thanks before days from now, but it seem that I forgot to do that. Sorry for my delay in say thank you …

You’re very welcome. Enjoy Fedora!