Help ! I'm no longer the administator of my computer!


I have a big problem right now. I just restarted correctly my computer after a long period and something really weird happened to me

First, the authentication page to put my user name and password became a sort of console window and not the usual welcome page.

Then Fedora keep asking me every three seconds to enter my password for every action I do

So in order to fix this, I upgrade my Fedora 32 to Fedora 33 hoping that would fix it. Well… it didn’t.

After several rebbots, I now face another problem, now fedora asks me for an “Administrateur” (yeah, I’m french) password for an admin account I never created and so never gave a password to

I’m now no longer part of my own sudoer group and the only way I could go back seems if I could enter that “administrator” session and grant myself root privileges again. But I don’t know that password and I’m not even sure it even exist or even if that “Administrateur” account exist to begin with.

Is there another way to regain root privileges or is there a default admin password so that I can solve my problem ?

Thanks in advance, I have no idea what to do

Also, here is an example of what’s popping every 5 seconds4726c707f29903c696442b1acb88ef85fefa1ef5.png

1 Like

Looking at the image posted, I understand that now you are able to log in in the system with your user. It seems that who is asking for the Administrator password is this PC/SC daemon. As far as I know it is related to smart card system.
BTW, are you able to open the terminal?

Well, that’s the thing, that pic was from before it went even more wrong.
I achieved to go again in the sudoer group by putting the init=/bin/bash to start a console

I then did
sudo mount -no remount, rw /
sudo usermod -a -G sudo < myusername >

and it worked to put me again in the sudoer group.

The problem now is that when I tried to restart fedora, usually when everything was green with an OK on each task, now everything is red and and fail.

When I try to log into my account I now have the error that it doesn’t know the user.

I did the init=/bin/bash again and checked with userdbctl < myusername > and it knows that I exist. So right now, I can’t connect to my session

1 Like

if selinux enabled did you run “touch /.autorelabel” after "sudo usermod -a -G sudo "?

if no try add enforcing=0 to boot and also add autorelabel=1 or after boot run “sudo touch /.autorelabel”

By the way, to make user administator you need to add the user to “wheel” group .


THANKS SO MUCH ! The autorelabel worked, now I have access to my session again.

Now back to the start, I still got those authentification pop-up coming up, but that’s at least that done.

The pop-up always says “authentification is required to access PC/SC daemon” every time I try to do something.

Also, something kinda weird that might be connected, every time I boot the PC on fedora, the start screen isn’t completely graphical, it looks like a mix between console and graphic and every time I try to connect the first time, it crashes and log me out. Then every second time, I have no problem logging in but then there are like 7 pop-ups asking my password and messages like the “authentification is required to access PC/SC daemon”


try add user to wheel group sudo usermod -a -G wheel < myusername >

I did it as well, maybe there is another group I should add for my username, but I can’t find which one

EDIT : Oh shit… I seem to have solved it with sheer luck, I searched for a random stuff on the net about having trouble to reactivate gdm and I found this command :

systemctl -f enable gdm.service

And with that I was able to remove all the messages I had


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.