Headset (phone + mic) option no longer available after upgrade to Fedora 33

My laptop has a 3.5mm combo port (headphone + mic). When I plugged my headset into that port on Fedora 32, a popup with 3 options would show up, and one of them was the full headset.
After I upgraded to Fedora 33, I don’t see that option anymore. I can now see the headphone and the mic, separately.
Is there a way to have that 3rd option back when I plug in the combo headset?

I tried one solution, but it didn’t work.

  1. I did cat /proc/asound/card*/codec* | grep Codec, and it showed Codec: Realtek ALC3254.
  2. I created /etc/modprobe.d/alsa-base.conf, and added options snd-hda-intel model=dell-headset-multi to it. Then did a reboot.
    That didn’t help, and I tried varying the model as headset-multi then as headset-mic (looked these up, and they all appeared to be other valid options for ALC3254).

This is not a big thing, as I do have a workaround (plug in the headset, then go to Settings > Sound, and select the correct mic from the dropdown), but it would be best to have the 3rd option back, of course. Grateful for any ideas, thanks!


For the records. A more or less recent update has solved this issue. At least on my laptop, the three options are here again.
@rtqate can you confirm?

Yes, the headset option is back. Looks like it is, indeed, after an update. Thanks!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.