Headphones don't show up until I run 'alsa-info.sh'

I’m running a new install of Fedora 32 on a new PC I built, and to make sure the headphone output jack was connected properly I tried plugging in some headphones. However, they didn’t show up as an output option in GNOME settings or in pavucontrol.

I tried looking around for solutions, and in the process I ran the command ‘alsa-info.sh --no-upload’, and noticed that afterwards the headphones showed up as an option in both GNOME settings and pavucontrol. Every time I have subsequently plugged anything into the audio jack this behaviour has been the same - they don’t show up until I run this command, after which they show up immediately.

For reference I am using an MSI B450-I motherboard, and I tried running Ubuntu from a Live USB, and there the headphones showed up immediately without needing to run any commands. I couldn’t find any similar issues anywhere, except from one person on Reddit who has the same issue, also with an MSI motherboard.

While I am satisfied that the headphone audio works, running this command every time I plug in headphones isn’t an ideal workaround, so I would appreciate any pointers towards a solution that would have the headphones show up as soon as they are plugged in. Any ideas as to why this behaviour is happening would also be helpful, as I thought the ‘alsa-info.sh’ command was purely diagnostic.

Thanks in advance!