Headphones (and mic) suddenly stop working

Hi there!

I have a very strange behavior on my Dell XPS 9700 laptop.

  • The internal audio (speaker) works perfectly fine
  • The 1.5mm jack plug from my USB-C adapter (HDMI output) also works fine


  • When I use the internal 1.5mm jack, both headphones and mic do not work

But here is the thing:

  • Headphones and mic are detected normally (plugged or unplugged)
  • Audio levels work as expected (gauges move along with the sound), but no sound can be heard
  • This is a new problem. Until then, headphones + mic were working perfectly fine.

What I tried:

  • I tried with different devices (speakers, other headphones). Same issue.
  • I booted on Windows to check if it could be a hardware issue. Negative! Everything works on Windows as expected.
  • I checked on alsamixer and pavucontrol but everything seems normal

Bottom line is: everything indicates that my headphones work but no sound goes out!

This is the output from alsa-info.sh:

Any idea how to fix this?

Apparently, it has something to do with the kernel, maybe a regression in a kernel audio module.

By switching back to an old kernel 5.19.14-201, I managed to get the sound back.

I’ll stick to kernel 5.x for now and move to 6.x if this problem gets fixed in the future.

1 Like