HDD not going into automated standby anymore


I’ve set my internal storage HDD to go into standby after 10 minutes via the Drive Settings in the Disks application (it’s supposed to turn off whenever I’m not accessing music/videos/ebooks/etc.). This has always worked well until a week or two ago (I don’t recall changing or installing anything particular around that time that would cause problems). I can still put the HDD into standby manually (Standby Now in Disks), but it does not do so automatically anymore, and I’m not sure why. My assumption has been that some process is accessing the hard drive and preventing it from turning off, but when I turn it off manually, it doesn’t just randomly turn back on either, so I’m not sure.

Has anyone had this issue before? Is there a way to check for processes keeping a drive from shutting down?

lsof DIR, probably.  I’m not sure.

Thanks, I’ve played around with this a bit, but lsof isn’t showing any files interacting with the disk. I’ve also tried iotop and dstat, and have found some periodic reads of the drive every 5 to 10 minutes, usually 1024B or 2048B , which seem to be source of the problem - they often take place the exact moment the drive is supposed to go into standby. Unfortunately they don’t seem to show up in iotop, so I haven’t been able to identify the source so far.

1 Like

Not really a solution, but it seems I can circumvent the problem by just reducing the automatic standby timer. At 5 minutes, it dodges the mystery reads fairly consistently and goes to sleep. I’ll leave this open in case anybody else has an idea for a more proper solution.

1 Like