HDD files not showing up after switching from windows to fedora

I just switched from windows to fedora, and this is my first time using linux.

I have 2 hard drives (512 GB SSD[sdb] & 1TB HDD[sda]) I have my system installed on the ssd one with “Automatic Installed” during the installation process.

My problem is that my HDD[sda] drive’s data is not showing up at all, I tried many solutions on google and youtube, one of them actually made me crash the entire system by accident and went through reinstalling it again. [NOTE that my SSD [sdb] drive is working fine and nothing it wrong with it, my only issue is with the sda one]

As I said it’s my first time using linux so I’ll try to give as many information as I could.

Thank you for your understanding, and I would really appreciate any help.

sda 8:0 0 931.5G 0 disk
├─sda1 8:1 0 1M 0 part
├─sda2 8:2 0 15M 0 part
└─sda3 8:3 0 931.5G 0 part /run/media/suhail/Main
sdb 8:16 0 476.9G 0 disk
├─sdb1 8:17 0 600M 0 part /boot/efi
├─sdb2 8:18 0 1G 0 part /boot
└─sdb3 8:19 0 475.4G 0 part /home
zram0 252:0 0 8G 0 disk [SWAP]

lsblk -f


ntfs Main D05AF32F5AF310C8 301.6G 68% /run/media/suhail/Main
│ vfat FAT32 864D-A1B5 584.8M 2% /boot/efi
│ ext4 1.0 67a2ef87-d7b7-4c3c-ab86-766b74332e82 698.9M 21% /boot
btrfs fedora_localhost-live
7bbc4470-0f3a-4961-a6e7-77b97e1d0df9 455G 4% /home

sudo fdisk -l
Disk /dev/sda: 931.51 GiB, 1000204886016 bytes, 1953525168 sectors
Disk model: WDC WD10JUCT-63C
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: FB7C1C53-F856-4663-8B64-6F9DDF3E6C16

Device Start End Sectors Size Type
/dev/sda1 34 2081 2048 1M Microsoft LDM metadata
/dev/sda2 2082 32767 30686 15M Microsoft reserved
/dev/sda3 32768 1953525134 1953492367 931.5G Microsoft LDM data

Partition 1 does not start on physical sector boundary.
Partition 2 does not start on physical sector boundary.

Disk /dev/sdb: 476.94 GiB, 512110190592 bytes, 1000215216 sectors
Disk model: SAMSUNG MZNLN512
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 9FC080FC-618D-45AA-9291-AA3C23B026BD

Device Start End Sectors Size Type
/dev/sdb1 2048 1230847 1228800 600M EFI System
/dev/sdb2 1230848 3327999 2097152 1G Linux filesystem
/dev/sdb3 3328000 1000214527 996886528 475.4G Linux filesystem

Disk /dev/zram0: 8 GiB, 8589934592 bytes, 2097152 sectors
Units: sectors of 1 * 4096 = 4096 bytes
Sector size (logical/physical): 4096 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes

1 Like

The drive is showing up and is mounted according to your lsblk output and the fdisk output.
Please be more detailed on what you expect and what is actually happening.

1 Like

Yes it’s mounted but there is no data, and as u see in the picture there is 600+ GB used, but when I open the mounted folder it tells me “folder is empty” and when I try to create files/directories it says
“input/output Error”.

could it be the filesystem of the sda [ntfs] ?

It probably is permissions and yes ntfs is a factor.

What do you see as ownership and permissions when you do ls /run/media/suhail.
Probably Main is mounted as owned by root even though it is mounted under your user name there.

With that mounted there you could do sudo chown -R suhail:suhail /run/media/suhail/Main which should change the ownership and allow your user to access the files.

Please be aware that linux ownership and permissions do not apply with ntfs and it is not recommended that you regularly store data there. It seems OK for media but for many other things it may present other issues, including the fact that in linux all files stored on ntfs are by default seen as executable.

There are ways to mitigate some of the differences but it is still not a great idea for regular usage.

How much of that 600+ GB is actual data you want to keep and how much is windows cruft from the OS that was left? I know that partitions 1 & 2 on that drive are windows left-overs.

1 Like

It still gives me I/O Error.

I don’t think windows craft is that much, I want to keep all the data actually.

i have the same problem
can you tell me ,if you fix it ? and how
thank you