Hardware Problems on new Schenker Notebook - Touchpad


a few days ago, I get my new Laptop from Schenker Technologies. I installed Windows 10 Pro and Fedora 33 Workstation (Gnome) as Dualboot, and after short time of using, I encountered some Problems under Fedora, which I don’t have under Windows. One of it is the Touchpad:

It sometimes isn’t recognized at Boot, so that I can’t use it. It doesn’t matter, if there is an USB-Mouse plugged in to during boot, in both scenarios sometimes it works, and sometimes not.
But when it works, only moving the mouse and left click works, right click doesn’t work (emulation by tipping with to fingers on the pad works).
The USB-Mouse works every time.

I have searched a little bit, but can’tfind any hint, what could be the problem. It doesn’t seem to be a missing driver, because it works sometimes.

Basic System Info:
AMD Ryzen 5 CPU, NVIDIA 1650 TI Graphic


Handle 0x0002, DMI type 2, 15 bytes
Base Board Information
Manufacturer: SchenkerTechnologiesGmbH
Product Name: GK5NxxO M20
Version: Standard
Serial Number: Standard
Asset Tag: Standard
Board is a hosting board
Board is replaceable
Location In Chassis: Standard
Chassis Handle: 0x0003
Type: Motherboard
Contained Object Handles: 0

Handle 0x0001, DMI type 1, 27 bytes
System Information
Manufacturer: SchenkerTechnologiesGmbH
Product Name: Schenker Media 15(M20, GTX 1650xx)
Version: Standard
Serial Number: -------------
UUID: ----------------
Wake-up Type: Power Switch
SKU Number: SME15M20
Family: RENOIR

[user@schenker-fedora ~]$ sudo dmidecode -t 8 [sudo] Passwort für user: # dmidecode 3.2 Getting SMBIOS data from sysfs. SMBIOS 3.2.0 present.

Handle 0x0015, DMI type 8, 9 bytes
Port Connector Information
Internal Reference Designator: J2304/J2300
Internal Connector Type: None
External Reference Designator: Keyboard
External Connector Type: PS/2
Port Type: Keyboard Port

Handle 0x0016, DMI type 8, 9 bytes
Port Connector Information
Internal Reference Designator: J3811
Internal Connector Type: None
External Reference Designator: Touch pad
External Connector Type: PS/2
Port Type: Mouse Port

[user@schenker-fedora ~]$ cat /proc/bus/input/devices | grep -i pad
N: Name=“UNIW0001:00 093A:0255 Touchpad”

[user@schenker-fedora ~]$ sudo dmesg | grep -E “touch|pad”
[ 2.171600] input: UNIW0001:00 093A:0255 Touchpad as /devices/platform/AMDI0010:01/i2c-0/i2c-UNIW0001:00/0018:093A:0255.0001/input/input7
[ 2.247918] input: UNIW0001:00 093A:0255 Touchpad as /devices/platform/AMDI0010:01/i2c-0/i2c-UNIW0001:00/0018:093A:0255.0001/input/input9
[ 2.248012] hid-multitouch 0018:093A:0255.0001: input,hidraw0: I2C HID v1.00 Mouse [UNIW0001:00 093A:0255] on i2c-UNIW0001:00

There is one week left within the 14-day-return-guarantie and I am really thinking about sending it back, so some hint’s if this problem is solveble are welcome.
Thanks in advance.

Looks like your trackpad is the same one that was giving problems in the following post. Have a look:


I have similar symptoms. My touchpad sometimes dies, sometimes it doesn’t.
Have the exactly same laptop model in arch wiki: https://wiki.archlinux.org/index.php/Lenovo_XiaoXin_15are_2020#Touchpad
I solved my touchpad problem as suggested in the archwiki, blacklisting the elants_i2c kernel module.

in /etc/modprobes.d/touchpad.conf:
blacklist elants_i2c

Note: This is the best I found, and this tweak worked for my laptop model. I also noticed https://bugzilla.kernel.org/show_bug.cgi?id=200529, but it doesnt’ seems to work.
Note: My laptop model will certainly be different from yours, but you can try the tweak that worked for me.
I uploaded my hardware information by using the command sudo hw-probe -all -check -upload, and my laptop model hardware information and system logs can be seen here: https://linux-hardware.org/index.php?probe=d689908218 (I uploaded this before this tweak, so my touchpad sometimes works sometimes dies, and the hw-probe happened when my touchpad works).

1 Like

Thanks, this looks very good. I will have a try tomorrow and report the result.

Thanks for the hints. I will first try, what Florian posted and If this doesn’t Work, I will continue with your Idea.

Maybe I could stay with this Laptop. Still have some Keyboard Problems, but this will follow tomorrow in an extra thread.

Not a solution, just some urls I can collect. (As a regular user, I have been frustrated about the damn touchpad, just trying to learn a bit more)
The best I can do is to search about:

  1. Commands that display what is going on here (e.g. confirm that is a kernel problem, excluding possibility to fix it by configuration to irrelevant files)
  2. Specific hardware reports about whether it is working or not.

I have learned a lot. For example:
journalctl --boot=-0 --priority=err -k to display kernel error messages for the last boot (the last time I turned on my laptop);
cat /proc/bus/input/devices to display input devices;
<editor name> /etc/module-load.d/<filename> to configure kernel modules loading;
sudo hwinfo > <filename> to display almost everything about my hardware (though the output is very long and not as simple as lsmod , lspci , lsusb , smartctl )

But all these commands just don’t solve problems, of course. (Configuring kernel modules order/ change them to built-in may work, but not for me, as the configuration is simply not recognized:
systemd-modules-load[1138]: Failed to find module 'softdep i2c_hid pre: pinctrl_amd'
systemd-modules-load[1138]: Failed to find module 'softdep hid_generic pre: pinctrl_amd'

For your case I think my tweak ( blacklist elants_i2c) will be useless ( though symptoms alike), as there may be nothing related to ‘elan’.
cat /proc/bus/input/devices | grep -i elan show up my touchpad, but as seen in your output:

There seems to be nothing related to ‘elan’ touchpad on your computer.
I searched for your device ID on https://linux-hardware.org/index.php?view=search&vendorid=093A&deviceid=0255&typeid=all#list and it does display some results. There seems to be working examples ot touchpads (‘detected’), but I guess these examples does not mean touchpads will work fine, they may also suffer from it. So sadly, no possible solution found.

As a regular user, I searched about:

  1. kernel command line tweaks. But sadly, _osi(Linux) is explicitly criticized by the linux kernel documentation, and will very likely to be buggy: https://www.kernel.org/doc/html/latest/firmware-guide/acpi/osi.html. On my computer, dmesg | grep -i osi shows:
    [ 0.415753] ACPI: Added _OSI(Module Device)
    [ 0.415753] ACPI: Added _OSI(Processor Device)
    [ 0.415753] ACPI: Added _OSI(3.0 _SCP Extensions)
    [ 0.415753] ACPI: Added _OSI(Processor Aggregator Device)
    [ 0.415753] ACPI: Added _OSI(Linux-Dell-Video)
    [ 0.415753] ACPI: Added _OSI(Linux-Lenovo-NV-HDMI-Audio)
    [ 0.415753] ACPI: Added _OSI(Linux-HPI-Hybrid-Graphics)
    [ 0.422012] ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
    [ 1.840065] hid: raw HID events driver (C) Jiri Kosina
    [ 24.167423] systemd[1]: Mounting POSIX Message Queue File System...
    [ 24.185345] systemd[1]: Mounted POSIX Message Queue File System.
    So it seems that _OSI(Linux), without acpi_osi=linux will be simply ignored by the kernel and the kernel will only respond to something more sophisticated.

  2. Blacklisting some sort of kernel module, which worked well for me. However, as the kernel bugzilla says, it may depends on booting order of modules, which is hard to discover; and with additional modules it doesn’t mean touchpad will certainly fail, which is also hard to discover.
    I see the exactly same model on archwiki (later a similar one on gentoo) so I’m in luck and find out what exactly to do.

There may exists better solutions, but as a frustrated user I cannot find anything better. I think coping with Xorg settings (as search engine results goes) will be completely useless: what can Xorg do if the device is not working in the kernel side?

I added acpi_osi=linux as argument to the boot-commandline via /etc/defaut/grub under GRUB_CMDLINE_LINUX (afterwards updated grub via sudo grub2-mkconfig -o /boot/grub2/grub.cfg
Then I tested some bootcycles (~7 times it was, I think) and the touchpad was recognized on every try.

Just the problem of the non working click with the right mouse key doesn’t changes with this fix :confused: and it is quiet annoying, because often it doesn’t simply not work, but it is recognized by the system as left click.

Have to take it back. Just did some more bootcycles because of another problem (maybe with the nvidia driver) and there it was again. Can’t say if it has an affect on the touchpad, wheather the graphics driver chrashes, but after I reinstalled the nvidia graphics driver from the non free repo, the next boot comes without touchpad.

Since my keyboard sometimes mixes up two keys functions, and sometimes chrashes while writing (seems like I unplugged the keyboard, but it is build in the laptopcase)(an extra thread for it was planned) and sometimes the system boots with an system error (I started an extra thread for it under https://discussion.fedoraproject.org/t/unknown-systemerror-after-boot/70594/3) and sometimes (I think it was 3 times in the last 7 days) the screen gets black and there is no other way then restart the system while loosing everything unsafed, I will try to send the laptop back.
Don’t know if they accept it, because they give no support for Linux. While waiting for answer I will go on trying to fix the Problems and report the results.

If the problem doesn’t happen on Windows, it’s not hardware and most probably they won’t accept the issue.

As related to my thread, unfortunately I haven’t resolved yet (I thought I did, but apparently not). The only solution so far is to reboot untill it works.

In my case there won’t be any touchpad recognized (either in hwls or directly in /proc/bus/input/devices), if it doesn’t work, this is why I don’t know what to do, but I can tell you that it works out of the box on Neon, which is a Ubuntu 20.04 derivated distro, which runs on kernel 5.6.

I’ve got in the list of things to do to install kernel 5.8 on the Neon SSD (I have to physically change the driver and I don’t have so much time as of now) to check if it’s kernel related (which is, most probably).

BTW any idea if it is possible to run kernel 5.6 on Fedora 33 anyhow to test?

I think I found a workaround for the touchpad not being always detected (probably, not had an issue after the hack).


I hope it will help you, too!

1 Like

Thank you for this Script. I will have a try and report the result. But I couldn’t do this today since there isn’t enough time. I will do it tomorrow.

Yes it is possible, that they don’t accept the issue and I would understand it. But I will have a try either, cause I spend around 1000 € for the Hardware and I am a little bit pissed off (sry) about Hardware only supported and optimized for windows. The Laptop ist good from the Hardware perspective and the price, but how could it be, that you just can use one OS with the Hardware. But thats another discussion for others Threads or plattforms.

1 Like

I will refrain from posting an advertisement here publicly, but I will send you a link from a hardware vendor from your country that ships Gnu Linux on their machines… guaranteed to work…

So a quick test of your Idea to reload the kernel Modul Looks good. About 10 reboots where Working good.
And I want to say thank you for all your Help.

The vendor accepted my wish to give the hardware back, so I will send it Back tomorrow. At this point thank you at the Vendor, because I would have understand, if they had declined it. In fact, there was a software incompatibility and no problem with the Hardware itself. Very good Support from Schenker Technology here.

So I can’t go on testing here. Because a quick test of the reload looks quiet good, I will mark it as answer, maybe somebody else with a little bit more patience can take advantage of this trick.


Sadly, my touchpad still occasionally dies after the archwiki hack. I am frustrated now and I will not attempt to try fixes any longer. Now I will try the touchpad on GNOME login screen and if it (thankfully, infrequently) dies, I just reboot the computer, and it shouldn’t die after the reboot

I have send my laptop back, because I found it annoying to reboot this often, as it requires to wait some seconds or select Fedora in Grub and unlock the encrypted disk at every boot.

But I ordered the Tuxedo Polaris 15, which is the same barebone as the Schenker Media 15, so it should be the same touchpad. Tuxedo supports their machines with some distros, so I ordered it with Ubuntu pre-Installed. This way I can check, if everything works. If yes, I will install Fedora and see, if it also works or if they offer appropriate drivers. If not, it also goes back and I will wait for some cool and for my budget and needs fitting ThinkPad as I have heard, they are working very good with Linux in general.

Or I wait for a full AMD machine, which is very rare at this time (ryzen 5/7 4xxxx and mid-class radeon gpu). Just know the MSI Bravo 15, but to reach the price of around 1200 €, they just built in USB 3.0 with 5/GBs and the chassie is said to be quit “flexible”. Also it is said to be very loud. So this isn’t what I excpect, when I pay this much money.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.