Guvcview + audio

Hey All,

Last year I recorded material for use as on-line lectures for my students using my laptop’s built in camera and a USB microphone using guvcview.

This year I have to each my classes remotely again :frowning: but guvcview doesn’t record audio anymore. Using either the built-in or usb microphone I record video just fine with guvcview (guvcview-2.0.6-8.fc34.x86_64), and audio seems to be detected and appears to be recorded, because the vu-meter style blocks appear and function as they would seem to be supposed to work. If I select the USB microphone as input and then scratch the microphone screen the blocks peg into the red. But the videos produced have no audio when I go to playback/shotcut them. I’ve tried two different thinkpads running Fedora 34, same behaviour.

Otherwise audio seems to be working fine on these laptops both playback all sorts of audio media just fine, and people on zoom meetings hear me fine… There was some audiosystem change with 34, is guvcview just depreciated and no longer working, is there something else I can use to record from the camera with audio?

Welcome to ask.fedora @petehurd

Yes pipe-wire is the new default sound-server in F34.

I don’t think so. But beside change to pipe-wire in F34 changed also Gnome to V 40.x , there is the possibility that guvcview is not 100% ready for it.

You could try to research about guvcview with pipe-wire and gnome 40.x

For the beginning you could check if guvcview works while you log in with x-org instead with the default Wayland (If you use the Workstation edition of F34?).

Have you ever tried to record your students with zoom it selves?

I normally work with the mate desktop, so I tried the wayland gnome and x11 gnome, both behaved just the same, clearly detecting and displaying audio input, but no audio in the recorded file.

I wiped my lecture prep laptop and reinstalled F33 so I can get work done that way, but left F34 on my other work laptops so can test other ideas…