GTA 5 leaves are glitched out on Fedora 36

For some reason GTA 5 leaves are glitched out, (sometimes missing and sometimes appearing as a blob) for me on GTA 5 with Fedora 36 Plasma 5.24.5 Wayland and Xorg. is this a Mesa bug?

Output for inxi -MCG

 Type: Desktop Mobo: Micro-Star model: MAG Z690 TOMAHAWK WIFI (MS-7D32) 
 v: 3.0 serial: <superuser required> UEFI: American Megatrends LLC. v: H.41 
 date: 05/17/2022 
 Info: 12-core (8-mt/4-st) model: 12th Gen Intel Core i7-12700K bits: 64 
 type: MST AMCP cache: L2: 12 MiB 
 Speed (MHz): avg: 4609 min/max: 800/5000:3800 cores: 1: 4832 2: 4898 
 3: 4736 4: 4900 5: 4892 6: 4800 7: 4802 8: 4843 9: 4892 10: 4900 11: 4886 
 12: 4821 13: 4837 14: 4163 15: 4892 16: 4900 17: 3801 18: 3802 19: 3798 
 20: 3801 
 Device-1: AMD Navi 22 [Radeon RX 6700/6700 XT/6750 XT / 6800M] 
 driver: amdgpu v: kernel 
 Display: x11 server: X.Org v: 1.20.14 with: Xwayland v: 22.1.2 driver: X: 
 loaded: amdgpu unloaded: fbdev,modesetting,radeon,vesa gpu: amdgpu 
 resolution: 2560x1440 
 OpenGL: renderer: AMD Radeon RX 6700 XT (navy_flounder LLVM 14.0.0 DRM 
    3.44 5.17.13-300.fc36.x86_64) 
 v: 4.6 Mesa 22.1.1


Thanks in advance for help!

Are you using proton, if yes then try different proton versions to see if that helps.Also update your system that might fix it if its driver issue

I tried different proton versions and no luck, I also did a fresh reinstall of fedora 36 and even with basically no modifications I still had this issue.

I think at this point only proton can fix this nothing else so I suggest to try proton GE, this may fix it for you. Here

protonGE reduced it, but the weird floating bubbles on some trees are still there.

Did you updated the OS because the iso that you downloaded might not have latest updates. If you already did that then I am not sure what I can do to help you. I really wish to help you out but this is as far as I can help you. You should try to change in game settings like vsync,motion blur and stuff like that, I know this might not fix it but you can try it to see if it works.

yes I updated everything before I tried playing GTA again. Thanks for the help

Oh and I just found out that apparently changing to protonGE didn’t help, the bug’s not there for a bit and then comes back after a bit.

I know, gaming on linux is improving day by day but there are still edge cases like this.So, at this point my suggestion would be that maybe wait for it you might get lucky and you get a fix or you just have to use windows if you want to play this game.

I found that the weird floating things and no leaves are fixed by disabling MSAA. Thanks for the help!

1 Like

That’s great and you are welcome. :slightly_smiling_face:

1 Like