GS/Mutter: Real Time Scheduler

Hi.
I have Silverblue Rawhide with last developement versions of Gnome Shell and Mutter installed.
I have tried to enable rt-scheduler (https://gitlab.gnome.org/GNOME/mutter/merge_requests/460) by:

$ gsettings set org.gnome.mutter experimental-features “[‘rt-scheduler’]”

$ setcap CAP_SYS_NICE=+ep /usr/bin/gnome-shell
unable to set CAP_SETFCAP effective capability: Operation not permitted

How to do it properly?

1 Like

I don’t think you can setcap because /usr is read only. You can run rpm-ostree usroverlay if you don’t mind the setcap being lost next boot.

1 Like

It is a pity that we can not set it permanently in Silverblue.

Is it enabled by default now (Rawhide)?
After upgrade and reboot:

[tpmajer@silverblue ~]$ ps -e -o s,pid,cls,pri | grep pidof gnome-shell

S 1284 RR 41
[tpmajer@silverblue ~]$ getcap /usr/bin/gnome-shell
/usr/bin/gnome-shell = cap_sys_nice+ep