Grub2 - how to remove a message?

I’m getting this message between grub and plymouth, "Booting bla bla… " in white text and black background

I found the line in the code…

grub_sprintf (s, "Booting '%s'", entry->title);

This issue is described also here
https://forums.gentoo.org/viewtopic-t-1121038-start-0.html

how can I disable it? and/or where can I report it? is redhat’s bugzilla the proper place or elsewhere?


❯ cat /etc/default/grub 
GRUB_TIMEOUT=2
GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_DEFAULT=saved
GRUB_DISABLE_SUBMENU=false
GRUB_TERMINAL_OUTPUT="console"
GRUB_CMDLINE_LINUX="rhgb quiet"
GRUB_DISABLE_RECOVERY="true"
GRUB_ENABLE_BLSCFG=true
❯ sudo grub2-editenv list
boot_success=1
boot_indeterminate=0
early_initrd=acpi_override
menu_auto_hide=1

OS: Fedora 37 Silverblue

Yes you can log in with the fedora-project account
https://bugzilla.redhat.com/

I don’t see that relatively new addition to the messages as a bug or problem. It clearly tells the user which kernel is booting just after the grub menu is passed (whether the grub menu is hidden or displayed) and only appears for a very few seconds.

The message does not come from grub2.cfg. It is coded into grub2 inself, and you would need to recompile it from source to modify this.

If the messages appears, depends on whether you let the boot menu time out or select the current entry by hitting the return key.

Supposedly you can disable the grub2 boot menu, and in this case the message should not appear, according to the source code.

The commit message reads:

Author: Hans de Goede <hdegoede@redhat.com>
Date:   Fri Jan 28 11:30:32 2022 +0100

    normal/menu: Don't show "Booting `%s'" msg when auto-booting with TIMEOUT_STYLE_HIDDEN
    
    When the user has asked the menu code to be hidden/quiet and the current
    entry is being autobooted because the timeout has expired don't show
    the "Booting `%s'" msg.
    
    This is necessary to let flicker-free boots really be flicker free,
    otherwise the "Booting `%s'" msg will kick the EFI fb into text mode
    and show the msg, breaking the flicker-free experience.
    
    Signed-off-by: Hans de Goede <hdegoede@redhat.com>
1 Like

Any time with ESC or Shift while booting. you should be able to make it visible.

I’ve never said it is a bug, I just want it gone but can’t find a way to achieve it…

I don’t need to know which entry is starting specially if you can’t do anything to stop it. IMHO that message is useless at that point.

Also don’t know from which moment it started to appear but before I didn’t have it.

If you ask me, I don’t think redhat’s bugzilla is the proper place to ask for help on this matter, that was one of the question I did ask here.(Where should I ask)

with timeout=5 (grub menu appears) and timeout=0 (grub menu does not appears) that message appears

I know is in the code, I posted the line of the code above. But I can’t find the reason for it to kick in (no matter what I do)

Here a possibile solution:

sudo nano /etc/default/grub

GRUB_TIMEOUT_STYLE=hidden

sudo grub2-mkconfig -o /boot/grub2/grub.cfg

Let me know if it resolves