Grub2 entry highlighted no longer first entry. How do I get Grub2 to highlight first entry?

I just installed the Xanmod RT kernel from the COPR repository, and have discovered that Grub2 no longer highlights the first entry for boot. I am aware that this can be changed with Grub Customizer, but I seem to remember that this isn’t the recommended way of getting the first entry highlighted at boot as default. Anyone? What is the recommended way of setting the first Grub2 entry as default? BTW, the Xanmod RT kernel works great so far.

sudo grubby --info=ALL

Then set it to the one you would like
sudo grubby --set-default /boot/vmlinuz<kernel version>

1 Like