Grub Slpash Screen and Lock Screen is broken?

After a recent update of video drivers(nvidia) and some updates, the grub menu appears and the lock screen is gone, I am back to seeing the grub menu and the lock screen look like a terminal prompt.

How do i fix the grub screen to hide it (blank screen) and also return the lock screen?

What I found only makes a fancy grub menu and the tutorial is from Fedora 6…

Hello @hamrheadcorvette,
What do the above images represent? Is the top what your system was doing before the upgrade? and the bottom one showing the request for your /home luks encryption? If you enter your passphrase do you then get to continue to the remainder of the boot process? A bit more info would assist in letting the community help you solve this.

Hello @jakfrost

This is after i installed the display driver install. The expected behavior is to not display the grub screen. It is supposed to be a black screen.

the expected behavior is the screen displaying a “lock” and request for password.

note: This was working flawlessly until a recent update to the driver and kernel.

Ok… This did not end well.

I found instructions on the " flickerfree boot for Fedora 29 " in an attempt to fix the issue. This left my computer unstable. I was unable to get back to the desktop and with no knowledge of how to get through grub commands I decided to “nuke and pave”.

I do have good backups so no harm no foul. After a clean install, I logged back into the system and proceeded with my backups and downloading all my updates except the NVIDIA video drivers.

Upon completion of the updates and backups I shut down and rebooted the machine. I went through a silent boot of grub and the LUKS splash screen. :grinning:GREAT ! :grin:

After shutting down and rebooting several times as a test, I proceeded with the Nvidia driver 440.59 install from the (Negativo17 repo) as I always have. This has worked well for over 2 months for me on Fedora 31, and for the entire time on Fedora 30/29 with the same spec machine.

Upon rebooting the machine, the grub menu appears again and the LUKS splash screen is gone again. I am effectively back to where i started.

A quick look at my backups for comparison, I noticed that after installing NVIDIA driver 440.59 from Negativo17 repo the grubenv.cfg located in /boot/grub2 the file does not have menu_auto_hide=1. after installing the driver it is omitted from the file. I have no knowledge of how to make that work, so i will leave it as is until i can test on a different machine.

A quick aside:
Anyone attempting to make changes to the grub splash screen or LUKS splash screen, attempting a silent boot, with an NVIDIA GPU should proceed with caution. Be prepared with a LiveUSB with a Fedora distro ready, and knowledge of grub commands just in case. Always have good Backups available as well.

Following commands from other distributions is also not an option. The process may differ greatly.

You should be able to modify the file as sudoer in vim, ie… sudo vim grubenv.cfg. Press <insert-key> to start inserting in vim, arrow down to the spot you want the line at, and enter it (copy paste is not an option). Press <esc-key> to exit inserting, then :qw <return-key> and it should write to the buffer to the file. Grub files can be modified manually.

Unfortunately with Nvidia GPU’s installed, modifying grubenv.cfg manually is simply not enough. Throughout the course of the day after the rebuild, I found out that modifying these files without applying several commands like:

grub2-mkconfig -o /boot/grub2/grub.cfg
and followed by
dracut /boot/initramfs-$(uname -r).img $(uname -r)

will simply not work. This is not an instruction on how to fix the problem, as I mentioned above Proceed With Caution. Modifying these files can leave you system in an unusable state.

Hello @hamrheadcorvette,
Thanks for the clarification. I know that Grub, as in Fedora’s usage of it, is going through the changes that started with Fedora electing to follow the Boot Loader Specification. I run Silverblue and have a BIOS based system, which further complicates things for me if I want to make changes to the boot loader. Grubby is now a script, and there is a deprecated version you have to specifically run for older Grub based installs as opposed to new installs. I read about it in the release notes but haven’t looked at it in depth.

1 Like

To add some closure to this post, i have not given up on trying to sort the issue. I have used a VM to explore changes made to configs to achieve a silent_boot for GRUB and the LUKS splash screen prompt to include any themes. I’ll post those results.