Grub menu not showing after installing Fedora as dual boot on a different partition

Yesterday I have installed fedora on a different disk on a special made partition on a different disk than my Windows boot. After restarting the computer Grub didn’t show up. I then tried tried reinstalling Grub, unhiding it editing it’s env, changing bios settings but nothing I do works. My BIOS is in legacy mode if that info helps. Thanks in advance!

Yes this helps. So as you have two different partitions you probably also have two different installations of Grub2 in your system. In legacy mode you have to set the disk you want to boot from as boot able.

You can check this wit gparted. When open, you have to look for the Partition > manage flags, While first clicking on the desired disk you want to boot from.

I guess Fedora changed this option as you chosen to write the grub2 to the same disk.

I am completely unable to even get any Grub to show up. It just automatically boots into windows without giving me any choice