GRUB loads always windows in safe mode

I’ve installed Fedora 31 on a notebook with Windows 10, GRUB shows me different options on boot, and when I choose Windows the system starts but always in safe mode. I have no options to load Windows 10 normally.

This is the boot sequence given by GRUB Customizer:

insmod part_gpt
insmod fat
set root='hd0,gpt1'
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt1 --hint-efi=hd0,gpt1 --hint-baremetal=ahci0,gpt1  B0DE-B937
  search --no-floppy --fs-uuid --set=root B0DE-B937
chainloader /EFI/Microsoft/Boot/bootmgfw.efi

And this is the result of fdisk -l command:

Device           Start        End    Sectors   Size Type
/dev/sda1         2048    1026047    1024000   500M EFI System
/dev/sda2      1026048    1107967      81920    40M unknown
/dev/sda3      1107968    1370111     262144   128M Microsoft reserved
/dev/sda4      1370112    2906111    1536000   750M Windows recovery environment
/dev/sda5      2906112 1406771199 1403865088 669,4G Microsoft basic data
/dev/sda6   1933588480 1937344511    3756032   1,8G Windows recovery environment
/dev/sda7   1937344512 1953523119   16178608   7,7G Windows recovery environment
/dev/sda8   1406771200 1408868351    2097152     1G Linux filesystem
/dev/sda9   1408868352 1933588479  524720128 250,2G Linux LVM

Can anyone help me setting up GRUB to load Windows correctly? Thanks

I suspect grub is working properly.

The issue likely is that you need to address a windows issue that is forcing the safe mode startup.

1 Like

Yes, it’s exactly what you said, I’ve solved with the following steps on windows:

  1. Click on Start
  2. Type msconfig (This will bring up the System Configuration window)
  3. Go to the Boot tab
  4. If selected, remove the tic from Safe boot
  5. Click Apply and then OK
  6. Restart your computer
1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.