Grub doesn't find Fedora boot entries with GRUB_ENABLE_BLSCFG=true

Hi. I’m trying to make blscfg work for my dual boot system (Fedora 40 KDE, W11). However, nothing I’ve tried was successful.

I’ve already read this discussion https://discussion.fedoraproject.org/t/missing-boot-entries-with-grub-enable-blscfg-true/70805 and tried fixes suggested there. Nothing helped but at least i got some information.

As far as I’ve looked, partition UUIDs in config files should be fine. /boot/loader/entries directory seems to be populated with correct .conf files. insmod blscfg and blscfg are being invoked before boot.

I tried some debugging as well (please keep in mind that it’s the first time I’m doing something like this), with debug=blscfg and invoking blscfg. It searches in (hd0,gpt1), but /loader/entries is in (hd0,gpt5). After set root=(hd0,gpt5), all the entries are found. This probably means, that there is some partition ID wrong in my configuration; however, as I said before, no mistake was found.

I’ve even tried reinstalling both operating systems. Partition-wise, /boot/efi is mounted on EFI System partition, then I have 1GB /boot partition, 30GB /, 130GB /home. /boot, /, /home fs is ext4 (tried btrfs as well).

Any help will be appreciated (I’m kinda livid because I’ve been trying to fix it for three days now)!

Added dual-boot, grub, uefi, windows

So what is gpt1 and what is gpt5. This should show up when running

lsblk -fp

Sorry for the wait, I went on a short unplanned vacation.
Here is the full output
NAME FSTYPE FSVER LABEL UUID FSAVAIL FSUSE% MOUNTPOINTS
/dev/zram0 [SWAP]
/dev/nvme0n1
├─/dev/nvme0n1p1 vfat FAT32 CC76-3854 50.6M 47% /boot/efi
├─/dev/nvme0n1p2
├─/dev/nvme0n1p3 ntfs 2A6E8BD26E8B956B
├─/dev/nvme0n1p4 ntfs C8AC4893AC487DC6
├─/dev/nvme0n1p5 ext4 1.0 3db6e829-eb24-45ae-82b0-f01ed3580dc3 584.6M 33% /boot
├─/dev/nvme0n1p6 ext4 1.0 12dc8908-257c-4861-ac45-b7dd0fc48443 6.8G 72% /
└─/dev/nvme0n1p7 ext4 1.0 a4654d78-6dfe-41e4-9199-387be8d558bf 118.2G 4% /home
I’ve read a bit about partitioning disk before installing operating systems, so hopefully there will be no mistake here.