Grub boots to black screen

Hi everyone,
two days ago i updated my almost fresh fedora 32 install (installed less than a week ago) and grub suddenly “broke”. It’s not really broken but has a really strange behavior that i can’t fix.

One week ago i did a full fresh install of both windows 10 and fedora 32. The are both running in uefi mode. After the installation everything was working fine, i loaded fedora entry, grub loaded, everything worked.

After a patch i did two days ago on fedora now grub does not load after bios. i end up with a full back screen after a single blink of a “_” in the upper corner of my screen. At first i thought that grub was broken… but it isn’t! If i open the bios setup and manually boot the fedora entry i get to see grub and everything works!

Almost forgot to say that i have secure boot enabled (No nvidia driver on fedora). I don’t think this is the root of the problem because i can still run fedora by manually selecting the first boot entry.

efibootmgr output:

BootCurrent: 0004
Timeout: 0 seconds
BootOrder: 0004,0000,0001,0002
Boot0000* Windows Boot Manager
Boot0001* CD/DVD Drive 
Boot0002  Hard Drive 
Boot0004* Fedora

This is really an annoying workaround to load grub, any ideas on how i should try to fix this?

I already tried to reinstall grub following this page:…nstalling.html
I also tried to regenerate grub config but nothing changed.

1 Like

Try to reset the GRUB environment:

sudo grub2-editenv create

Tried and nothing changed

1 Like
cat /etc/default/grub; grep -v -e ^# -e ^$ /etc/fstab; \
lsblk -o +FSTYPE,UUID; sudo efibootmgr -v

What is the output?

GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
GRUB_CMDLINE_LINUX="resume=UUID=d42cc13e-21e3-40b0-8cf9-11dfb06b1711 rhgb quiet"
UUID=556c62be-125d-4706-9de1-2eb6722984f7 /                       ext4    defaults        1 1
UUID=3EA4-87B0          /boot/efi               vfat    umask=0077,shortname=winnt 0 2
UUID=5c9734d7-eb04-4744-b2c1-93981f55e903 /home                   ext4    defaults        1 2
UUID=d42cc13e-21e3-40b0-8cf9-11dfb06b1711 none                    swap    defaults        0 0
sda    8:0    0   1.8T  0 disk                   
       8:1    0   1.8T  0 part            ntfs   888AB9D88AB9C34C
sdb    8:16   0 931.5G  0 disk                   
│      8:17   0   100M  0 part /boot/efi  vfat   3EA4-87B0
│      8:18   0    16M  0 part                   
│      8:19   0 487.7G  0 part            ntfs   D820B1EC20B1D1AC
│      8:20   0   517M  0 part            ntfs   E0624CE3624CBFD0
│      8:21   0   200G  0 part /          ext4   556c62be-125d-4706-9de1-2eb6722984f7
│      8:22   0   1.9G  0 part [SWAP]     swap   d42cc13e-21e3-40b0-8cf9-11dfb06b1711
       8:23   0   240G  0 part /home      ext4   5c9734d7-eb04-4744-b2c1-93981f55e903
sdc    8:32   0 931.5G  0 disk                   
│      8:33   0 486.8G  0 part            ext4   1521a9e9-bac9-4826-a31d-f1847f46d6cc
       8:34   0 444.8G  0 part            ntfs   38E24879E2483D7E
sr0   11:0    1  1024M  0 rom                    
BootCurrent: 0004
Timeout: 0 seconds
BootOrder: 0004,0000,0001,0002
Boot0000* Windows Boot Manager	HD(1,GPT,d5798339-dc26-4cd1-8c90-36ad9d8c87c4,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}...M................
Boot0001* CD/DVD Drive 	BBS(CDROM,,0x0)AMGOAMNO........o.T.S.S.T.c.o.r.p. .C.D.D.V.D.W. .S.H.-.2.2.4.B.B....................A...........................>..Gd-.;.A..MQ..L.8.R.S.W.8.6.C.B.0.A.A.1.M.1. . . . . . ......AMBO
Boot0002  Hard Drive 	BBS(HD,,0x0)AMGOAMNO........o.W.D.C. .W.D.1.0.E.Z.E.X.-.0.0.R.K.K.A.0....................A...........................>..Gd-.;.A..MQ..L. . . . .W. .-.D.M.W.1.C.2.S.>..Gd-.;.A..MQ..L. . . . . . . . . . . . .3.Z.0.4.E.2.9.R......AMBOAMNO........o.S.T.>..Gd-.;.A..MQ..L. . . . . . . . . . . . .9.Z.V.A.A.S.C.X......AMBO
Boot0004* Fedora	HD(1,GPT,d5798339-dc26-4cd1-8c90-36ad9d8c87c4,0x800,0x32000)/File(\EFI\fedora\shimx64.efi)
1 Like

Try to upgrade the BIOS/EFI firmware if possible.
In addition, reset the BIOS/EFI configuration.
And the EFI boot configuration specifically.

My mobo is not exactly new and there are no patches that i can do.

I tried to reset the whole bios to default settings but the behaviour is still the same.

I can boot directly in windows is i leave it first in boot order, but grub (fedora entry) keeps going into a black screen if i don’t run it manually from bios boot menu

1 Like

Actually, there’s an updated documentation:

Thank you for your help, i managed to fix just by making some changes to grub config. It was too strange to be able to boot my os just by manually selecting fedora entry.

In /etc/default/grub in updated/added this:


Then I regenerated my config with:

sudo grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

Now grub shows up at full screen, at the end of the day maybe i run into some kind of issue in the way grub tried to display its own menu when it was automatically run after bios.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.