Graphics card lags

Greetings everyone. Right now i’m experiencing “new user difficulties”
i’ve just transferred from Windows and right now my graphics card can’t give me the perfomance it did when i was on windows.
Simple 420p videos are lagging (losing frames?)
and a lot of tabs in my browser are constantly closing on their own, especially with highly graphically intensive ones

the tabs are just breaking and i have to constantly reload them after which they are breaking again in 15 seconds. the UI of gnome is also breaking often - after almost each suspend i have to restart my pc to start again.
i’ve tried to update drivers for my NVIDIA GTX 560 TI automatically by adding RPM fusion - it helped, but not much
i’ve also tried to install a driver manually, by following this guide, but during the final phase it gave me an error and i had to abort.
The log of an error is avalible if it helps.
Any suggestions? would really appreciate any help!

I would suggest installing the drivers using RPMFusion repositories, once you have cleared out the changes made from the RUN file. Here’s something that might be of assistance,

the rpm fusion drivers are already installed and it didn’t really help - video fps is still very low

Are you sure that your video player is running off from the discrete graphics card or is it running from the integrated one? The differences can be very contrasting in both of their performances.

on’t really know how to check it - would be nice if you’d help!

Please check on the Enable Graphics API Visual Indicator check box on your NVIDIA Settings application like it is shown below. (I have unchecked it because I have a PRIME configuration employed which renders everything using discrete GPU so I do not need to distinguish between multiple renderers but you do)

Also, screenfetch should return either only NVIDIA GPU (PRIME config) or both NVIDIA and Integrated GPU (OPTIMUS config). Here’s an example screenshot for you.

Let me know of your findings.

i don’t really have such a setting, and in terms of OpenGL - when i’m starting up my PC i’ve got steam starting up automatically, which is also giving me an error about OpenGL not working correctly.

here is my screenfetch output

If you’re using Fedora Workstation, you would find a “Run with Discrete Graphics Card” option on the menu when you right-click on the apps on the app drawer. Please check if that helps.

i don’t really have such an option!

as you can see in the screen fetch - it doesn’t even initialize my graphics card which is really odd!

Four gigabytes probably isn’t enough for that many tabs. They are probably being killed by the OOM service to keep things running. You probably need to install more RAM in the computer if possible. Alternatively, workarounds would include enabling/increasing ZRAM and/or using an environment that requires less memory like LXDE or i3.

I suspect the video is lagging because the OOM service is taking priority on the CPU to recover memory (by killing things).

though - while i was running windows it worked perfectly fine even with 1080 p
and a lot of ram usage simultaneously

and a problem of not identifying my graphics card still remains

I’m guessing it was an older version of Windows if it ran on only 4GB of RAM. None the less, since you appear to be running Fedora Linux 33, I would suggest starting by increasing the ZRAM size. What is the current content of /etc/systemd/zram-generator.conf?

Try changing it to the following and reboot to see if that helps:


such file does not exist

Hmm. Do you have any swap space at all? What is the output of free?

i’m not shure - but swap exists

It is using swap heavily – a definite sign that the system has insufficient memory for what it is trying to run. ZRAM should still perform better than using disk though. Go ahead and create the zram-generator.conf file and reboot.

rebooting now