GNS3 - Running As A Daemon - Fedora 34

Good morning all,

I’m trying to run GNS3 as a daemon, I’ve done this before on Ubuntu, but on Fedora it seems a bit different.

What I’ve done so far:

  • sudo nano /etc/systemd/system/gns3.service

In the file:

Description=GNS3 Server




  • sudo chmod +x /etc/systemd/system/gns3.service
  • sudo systemctl enable gns3
  • sudo systemctl start gns3

When I try to confirm if the service is running, I get this output:

  • sudo systemctl status gns3
Active: failed (Result: exit-code) since Thu 2021-08-05 10:59:41 CDT; 15min ago

Aug 05 10:59:41 gns3s2 systemd[17669]: gns3.service: Failed to locate executable /usr/bin/gns3-server: No such file o>
Aug 05 10:59:41 gns3s2 systemd[17669]: gns3.service: Failed at step EXEC spawning /usr/bin/gns3-server: No such file >
Aug 05 10:59:41 gns3s2 systemd[1]: gns3.service: Main process exited, code=exited, status=203/EXEC
Aug 05 10:59:41 gns3s2 systemd[1]: gns3.service: Failed with result 'exit-code'.

I can navigate to the file and launch it manually without any issues.



Its reporting it can’t find gns3-server.

What is the output of:

which gns3-server


ll /usr/bin/gns3-server (or ll the output of the which command).

Thanks Tom.

1 Like

Hi Tom,

When I run:

  • which gns3-server
[gns3s2@gns3s2 ~]$ which gns3-server
/usr/bin/which: no gns3-server in (/home/gns3s2/.local/bin:/home/gns3s2/bin:/usr/local/bin:/usr/bin:/usr/local/sbin:/usr/sbin)


  • which ll /usr/bin/gns3-server:
[gns3s2@gns3s2 ~]$ which ll /usr/bin/gns3-server
alias ll='ls -l --color=auto'
/usr/bin/which: no gns3-server in (/usr/bin)

This is the output of pwd:

[gns3s2@gns3s2 bin]$ pwd

This is the output of ls:

[gns3s2@gns3s2 bin]$ ls | grep gns3

whoops it should be gns3server

It’s working now Tom, you helped me notice it after I backtracked to check my config and output the file name, haha!



Glad to hear its sorted.

By way the 2nd command should have been without which, so with the new filename in mind; it should have been:

ll /usr/bin/gns3server

Sorry tried to make that as clear as I could.

Thanks Tom.

Thank you, I knew I was doing something wrong and I am glad you pointed that out

Love learning new things, thank you, sir! I appreciate the help

1 Like

Unrelated to this issue, I wanted to know why is GNS3 on Fedora got getting updates?

Just seen this James,

Are you stuck on a certain version? If so which version?

I am on version:

  • Running GNS3 version 2.2.23 on Linux (64-bit) with Python 3.9.6 Qt 5.15.2 and PyQt 5.15.0.

However, I manually updated my GNS3 client + server to that version

Prior to that, I used this guide for the latest official GNS3 install:

But to answer your question, I believe Fedora isn’t getting the latest updates because GNS3 is based on Debian (Ubuntu) and not Fedora

So any updates for GNS3 on Fedora’s side would have to be pulled from either the official GNS3 Github:

Or from guides like the one I linked above, hopefully that answers your question

I’m not entirely sure who maintains the official repo (when you install GNS3 and run the commands “dnf install update”) but there are very little guides covering GNS3 on Fedora. I would like that to change, that would be awesome because I am loving fedora so far!

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.