Gnome won't start after upgrade to Fedora 31

Hi! After upgrading my Fedora 30 to Fedora 31 using the “Update” tab in Software, Gnome won’t boot after initial loading, and I’m locked in the screen just after the loading circle disappears.
I’ve tried booting in terminal mode, adding 3 to the Grub entry, and this does work, but I don’t really know how to check what’s the issue. I guess it is something related to NVidia drivers since that has caused problems in the past but I don’t know enough about Fedora or Linux in general to be sure.

My computer is an MSI Laptop, the GE62VR 6RF Apache Pro

Here is the output of both lspci and lsusb commands:

I know that’s not much information, so if there’s anything else that would be needed to diagnosticate what’s going on, just ask me!

I hope someone can help.
Thanks in advance

I already tried to post a different thread before, but I think it didn’t get accepted because of me being labeled as a “new user”, now I should have the requirements to post.

So after having trouble with my upgrade to Fedora 31 because of Gnome not loading, I decided to uninstall and reinstall all NVidia drivers, and it worked. However, after the loading screen, GDM did not load and Fedora asked me to create a new user instead, not recognizing my existing user.
I looked at the journal to see what was wrong and I found a ton of lines similar to this:
SELinux is preventing gdm from read access on the file /var/lib/sss/mc/passwd.

My next step was to disable SELinux for the next boot, and it actually worked!
Nonetheless, I’m pretty sure this is not intended and I’d like to know how I can fix this (besides just adding selinux=0 to the grub entries…)

Thanks in advance for your help :slight_smile:

Hello @vherrero, welcome to the community.
Sorry for the trouble. The problem was that you posted in the #english top level category; posts in this category will go in the moderation queue. As you can read in #start-here, you are supposed to select a subcategory.

Talking about your issue with selinux, probably you have to trigger a relabel of the specific directory with
sudo restorecon -v -R /var/lib/sss/mc/passwd
Or for the entire file system with
sudo touch /.autorelabel
then reboot.

But! Better to wait the opinion of other people more expert than me! :slight_smile:


Hi again @alciregi!
So, as there weren’t any other replies to the post and seeing that the problem wasn’t only in that specific directory according to the logs, I tried the second option and relabeled the entire file system.
It didn’t take that long and after that the problem was solved!
Thank you so much for your help and your patience! :smiley:

I’ll be more careful next time I post to pick the adequate category :wink:
Have a nice day!


I’m happy that you solved your issue.
You are welcome.

P.S. another function of this forum is the “mark as solved” checkbox that you can find at the bottom of each reply. Tick it if an answer is the resolution to your issue: in this way you help other users in finding useful answers if they encounter the same issue. :+1:

1 Like

Whoops. You already did that. :smile:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.