GNOME Software stuck in an endless loop

Hello Silverblue users and developers,

Last week I rebased Fedora Silverblue to versions 32 and since then, when the desktop is loaded and the systems checks for a new update, GNOME Software seems to get stuck in an endless loop searching for new packages.

The error message that is shown is:

Unable to get list of updates:
Error calling StartServiceByName for org.freedesktop.fwupd: Timeout was reached

Reading the error message, I understand that the server with the firmware updates (fwupd) can’t be reached.

Does anybody else have the same error? Does anybody know how to solve the problem?
Updating the system with the command line (rpm-ostree upgrade) works fine.

Scott Trakker

Hi scotttracker and welcome back to the forum!

Have a look at this GitHub issue, the Gnome Software error is identical, altough the person reporting the issue was able to update via Gnome Software (no loop was experienced).

This thread seem to have a possible solution: fwupd fails to/very slow to start with Logitech G610 keyboard · Issue #2047 · fwupd/fwupd · GitHub

Hello Returntrip,

Thank you very much!
The solution was indeed on the pages that you mentioned!

I will post the solution here for everybody who has the same error.

Open the config file of fwupd
sudo vim /etc/fwupd/daemon.conf

Set the attribute EnumerateAllDevices to false

Save the file and reboot the system to check if it has an effect.

I have no clue what the attribute does but it works!

Scott Trakker


Thank you Scott. Just to add that on my SB32 it is already set to false. I’m on SB version 32.20200602.0 (2020-06-02T01:07:49Z).