Gnome Software show "Update failed" notification at boot


After updating from fedora 35 to fedora 36 testing, gnome-software keep showing this popup at boot, even when I haven’t done any updates.

The translation of the popup is “Update Failed: The update was canceled”.

It is my understanding that with a version that is still in testing (now beta) that a good practice is to manually do all updates and not use the gnome-software tools to do the updates for you. The chances of having something fail with the auto update are greater, and also the gnome-software tools for auto updates may not be fully active yet.

If you use dnf and do a sudo dnf upgrade regularly when you first start for the day it probably will prevent those messages (or at least reduce the frequency)

I have not used gnome-software to upgrade my system but I used dnf system-update command. After the end of upgrade, at every boot, the system shows me that message. I’m continue to investigate and found a systemd service called systemd-update-done.service. I have viewed the status of this service and I found this:

[gdramis@huawei-matebook-d14 ~]$ systemctl status systemd-update-done.service
○ systemd-update-done.service - Update is Completed
     Loaded: loaded (/usr/lib/systemd/system/systemd-update-done.service; static)
     Active: inactive (dead)
  Condition: start condition failed at Fri 2022-03-25 13:00:43 CET; 2min 39s ago
             ├─ ConditionNeedsUpdate=|/etc was not met
             └─ ConditionNeedsUpdate=|/var was not met
       Docs: man:systemd-update-done.service(8)

I suppose the problem is related to this service or something similar.

I am not sure why you would be using that command. dnf system-update since I am reasonably certain that command does not exist on most systems.

A normal update is done using sudo dnf upgrade for doing updates on a regular basis. A full system version upgrade, such as upgrading from fedora 35 to fedora 36 would use sudo dnf system-upgrade download --releasever 36

Thus I cannot tell what you are actually saying since the command you post is not valid. Without the actual command the remaining part of your post makes little sense.

Note that the command I gave above is only step one and after it completes successfully it must be followed by the second step sudo dnf system-upgrade reboot to actually complete the upgrade.

Instructions shown on screen when doing the download also suggest that you do a full system update using sudo dnf upgrade --refresh before starting the download to ensure the upgrade is completed properly.

If you did all the above and are still getting these popups then I suggest that at this time you do sudo dnf distro-sync --refresh to get the system fully in sync with the repos.

Sorry it was my mistake, I meant system-upgrade and not system-update. Beyond that, the procedure I carried out was exactly the one you described. And in fact, all packages are updated to the latest version. The only problem is that notification on every boot.

1 Like

Run ‘pkcon refresh force’ in terminal ,reopen software application and try to update software and see it will appear again notification . if yes run ‘flatpak update’ in terminal and reopen software application and update it

1 Like

I followed your instructions a few days ago but kept getting that error message.

Hi everyone, I’m on Fedora 36 beta and I have a similar error message.
I’ve done all the updates.

I have the same issue. I’ve tried clearing every kind of cache that I could find, PackageKit, dnf, gnome-software. Doesn’t matter. I think it’s related to systemd-update-done.service as well, but I might have to experiment some more.

I believe that pop-up is related to packagekit and gnome-software.

You might try doing both sudo dnf upgrade --refresh and sudo pkcon refresh from the terminal window then reboot and see if it continues. These commands should ensure the cache for both dnf and packagekit are in sync with the repo and inconsistencies between the caches is what usually gives that message.

I’m having the same issue describe by the other users and none of the solutions suggested actually worked:


I installed f36 beta a few weeks ago and it seemed to popup after I changed a kernel flag (although I’m not 100% sure). Also a few days ago after a big chunk of updates the error didn’t appear, but i came up again after a couple of reboots.

Also, maybe just a coincidence but all three reporting the issue are italian, maybe something broken in the translation package?

I installed F36 Beta and i have the exact same issue, the notification comes up after every reboot. All packages up to date. My system is german so i dont think its a translation problem.

Fixed on Fedora 36 release