Gnome Software package installation constantly pending

When i tried to play a video some months ago, fedora offered to install missing packages. Installation didn’t go well and these packages staying for months there pending installation.
Everything i tried did not work
a) I installed and uninstalled these specific packages but still packages with same name stay there “pending installation.”
b) trying various terminal commands but finally didn’t manage to remove these packages.

any idea how to clear gnome software from these packages?

1 Like

Try to clean the system and session caches:

sudo dnf clean all
sudo pkcon refresh
dnf clean all
pkcon refresh
1 Like

Thanks for your tips vgaetera!
If i remember well i tried these commands few months ago with no results.
Tried it again but it didn’t work. Packages pending installation still there…

A) Maybe it is a problem in the cache of gnome-software or your user (more extensive affect others applications but is not a problem is ok clean it sometimes) try clean it:

rm -r ~/.cache/gnome-software/* (remove only the cache of gnome software center)

rm -r ~/.cache/* (remove the cache of your user)

Now make a clean chache or metadata

sudo dnf clean all && sudo dnf makecache

After than you did clean the cache of (gnome-software/your user) log out and log in again in your gnome sesion.

B) Disable and able (again) your rpmfusion repos to delete this packages

If option A did not the work try it:
If i am right this packages is from rpmfusion you should disable these repos before to delete these packages and after turn on them again. You can disable these trought gnome-software or via console.

Via console:

  1. List your repos
    dnf repolist

Note: Repos that show the symbol * in the begining of their ID are actived

  1. Disable the rpm-fusion that do contain the packages
    sudo dnf --disablerepo <repo id>

  2. Now run
    sudo dnf clean all && sudo dnf makecache

  3. Look if the packages is still there, if they are try delete them via console if gnome-software can not
    sudo dnf remove <package>

  4. Turn on the disabled repos
    sudo dnf --enablerepo <repo id>

  5. Update system
    sudo dnf update

  6. Log off and log in in your user sesion.

I hope this help.


Tried xtym advise (a+b) but unfortunately packages stay there pending installation.
However there is a change now: after enabling repos again (b advise) offending packages cant be selected for installation. They stay grey. I think this is ok behavior because these packages are pending for installation so its normal that i cant select them again.


You can try to isolate the problem checking it under another user.
The issue is system-wide if it persists, otherwise it is user-specific.


try first force kill gnome-software then remove ~/.cache/gnome-software and and any folder related to gnome-software in ~/.config ~/.local/share .


Try isolate the problem like vgaetera adviced.

you also can try reinstall gnome-software package, maybe it can clean something what was wrong.

sudo dnf reinstall gnome-software

A solution more agresive is remove or install this again:

  1. Remove gnome-software

sudo dnf --noautoremove remove gnome-software

  1. reboot the PC before you do the clean install

  2. Now clean install

sudo dnf install gnome-software


ok, tested with a new user. No problems. So it is user specific. I ll try later to clean all related folders from my home dir

Thanks you all for the advise. Finally after cleaning gnome-software related folders in ~/.cache/gnome-software and ~/.config ~/.local/share and

sudo dnf clean all
sudo pkcon refresh

everything is clear, packages gone from “eternally” pending installation state


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.