Gnome Software Center Updates Error

Same result as [ sudo dnf mark install kernel kernel-modules ].

A side note, I can still install and remove packages from the store, I just can’t check for updates. I’ve also tried completely removing and reinstalling all NVIDIA-related packages, but to no effect.

What if you try to add verbose flags to dnf?
sudo dnf update -vvv

Here is the result:

The command stops right after dependency resolution, which I’m guessing explains the store’s message, depsolve transaction.

Have you tried …

dnf clean all before running the update command?

You can use sudo dnf repoquery --unsatisfied to display broken dependencies. May be worth a try.

Finally, I would issue a sudo rpm --rebuilddb to rebuild the rpm database. That may fix your problem.

I just tried both [ dnf clean all ] and [ sudo rpm --rebuilddb ], but the terminal shows the same error. After running [ sudo dnf repoquery --unsatisfied ] with the [ --verbose ] option added to the end, I got this:

The only errors seem to be in the fedora-updates-modular repo, which would explain what’s happening.

Next thing to do is disabling all unused (modular?) and all third-party (adobe, skype, :frowning_face:) repos and the-run above commands.

Well… playing apprentice wizard: maybe --noautoremove

I tried both commands, but the repoquery gave the same result and the system still won’t update. I’m thinking I may need to completely remove and replace the [ fedora-updates-modular.repo ] file in the [ /etc/yum.repos.d ] folder. How would I go about safely doing so?

I’d like to know the output of “sudo dnf repoquery --whatconflicts kernel-core”.

To safely deactivate some repositories, I think I would launch gnome-software, in upper-right click the icon with horizontal lines, click software repositories, and deactivate one/some repositories. So that you could easily re-“Enable” them later.

Seems to give the same result as the [ sudo dnf repoquery --unsatisfied ] command:

maybe sudo dnf --exclude=kernel-core update
just found this reading in an other question

BTW: I think it would be ‘better’ if you just a copy and paste the text, select the text then press (Ctrl+Shift+C) to make it a preformated text block.

All non-kernel packages were able to update successfully. [Good news] But I still cannot update the kernel itself. The store still has the depsolve error and the “Unexpected System Error” prompt still appears at startup.

Also, thanks for the tip, sorry if I’ve been posting wrong.

1 Like

1442954 – Can no longer update - "The operation would result in removing the following protected packages: kernel" suggest to do “sudo ls /etc/dnf/protected.d/*.conf” I think it will show a /etc/dnf/protected.d/kernel.conf it has been said that removing this file could resolve the problem… I think it is nvidia-driver that is protecting your kernel from upgrade, because upgrading your kernel might brake your video driver! Remember, nvidia-driver is not open-source, and driver in Linux need to be adjusted on a kernel upgrade, that’s why almost all of them are shipped with the kernel. So I think you are suppose to wait for an update of nvidia-driver, remove it, upgrade the kernel, re-install the nvidia-driver… I might be wrong however! :grinning: Maybe the system is bright enough to know that it can upgrade the kernel on a new version of nvidia-driver (really unsure). In 1767354 – The operation would result in removing the following protected packages: kernel-core, systemd the problem seems to have gone by itself… The operation would result in removing the following protected packages: kernel-core, systemd - test - Fedora Mailing-Lists also talk about almost identical situation.

Oh… (a)kmod-nvidia, “just” have been bump from 440.64 to 440.82 in rpmfusion nonfree updates testing! “An akmod is a type of package similar to dkms. As you start your computer, the akmod system will check if there are any missing kmods and if so, rebuild a new kmod for you. Akmods have more overhead than regular kmod packages as they require a few development tools such as gcc and automake in order to be able to build new kmods locally.” I could guess from that, that the kmod-nvidia package install the kernel protection for not upgrading the kernel… and akmod probably not, because it will build it a boottime if not already built (which means the “first” boot will be long after the update). Still, upgrading a kernel even with amod is risky because it might not been upgraded to work with more recent kernels.

The command: sudo ls /etc/dnf/protected.d/*.conf

Only shows the following entries:
/etc/dnf/protected.d/dnf.conf /etc/dnf/protected.d/sudo.conf /etc/dnf/protected.d/systemd.conf

I’ve also tried to manually uninstall all NVIDIA software from that repo by using the dnf remove command, but to no effect. Interestingly, I’ve never been able to install updates using the dnf update command unless the most recent kernel had been installed from the software center. Only after updating through the store and restarting, could I use the dnf update command to install any other non-official packages. [IE it’s as if the store and the command are separated.] I always thought it was normal, but I suppose not. I am dual-booting, if that helps.

Could it be possible that copying the .repo files from another installation would resolve the problem?

Turns out it was not related to the NVIDIA drivers. To resolve, I did the following:

Marked all “kernel” packages as user-installed with the command:
sudo dnf mark install $(dnf repoquery --installed 'kernel’)*

Changed my maximum number of kernels from 1 to 0 [disabling the mechanic altogether]:
Type in terminal: sudo nautilus
Navigate to directory: /etc/dnf
Open: dnf.conf
Set: " installonly_limit " to " 0 "

Restarted and ran: dnf update
Checked for updates through the software center just to verify that the problem was solved.

You may also need to mark the kernel modules as user-installed, but this step is likely not relevant. [I also forgot the command I used to do this…]

This is a known bug. Does no harm, until now. and people are on it. Bug 1731758 - Detailed errors from the package manager follow: Error calling StartServiceByName for org.freedesktop.fwupd: Timeout was reached

See also

(yes, the thread doesn’t belong there but it’s there), and

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.